Jump to content
Do Not Sell My Personal Information


MyToyota App


Roy124
 Share

Recommended Posts

I have been using the MyToyota App with interest but from time to time it will not open.  It has now failed to run on more than one device for over a week.  

I enter MyToyota and it reports: Error It seems you don't have an internet connection. OK

Of course I have a good connection.

I press OK and it takes me to the Log in to MyT and asks for email and password.  I enter the details and it immediately returns to the Error message.

I suspect the fault lies with the Toyota site.  Any clues?

Link to comment
Share on other sites

  • 5 months later...

MyToyota App has suddenly changed.  I used to check my trip data and driving coach experience.  After yesterday's trip all I get is my Car Data and its location, no trip data at all.  Have others experienced this change?

I have an idea but it is just that, an idea.

Link to comment
Share on other sites

On 1/12/2021 at 3:03 PM, Roy124 said:

MyToyota App has suddenly changed.  I used to check my trip data and driving coach experience.  After yesterday's trip all I get is my Car Data and its location, no trip data at all.  Have others experienced this change?

I have an idea but it is just that, an idea.

The trip data that used to appear on the opening page seems to have gone but can still be accessed via Services - Hybrid Coaching - All Trips.  So it is still available, just not so obvious!

  • Like 1
  • Thanks 1
Link to comment
Share on other sites


New owner MY21 2.0 ts here with many questions!!

let's start with a basic one.

When phone is connected (android auto) with original usb cable (huawei) even though maps, phone  call, calendar etc are available and work ok so far the usb option configuration on the phone is stick to charge only. If I choose to media files trasfer if stays for a second and the comes back to charge only.

is this the reason why I still dont have any data in the "coaching" section. Everything is still 0!!!!

 

what am I doing wrong? I am lost, cause most of the guides/manuals dont explain this part...

hdrpl.jpg

  • Like 1
Link to comment
Share on other sites

navger, I think your phone gets the coaching and data from the Toyota servers and not from any link to the car.  The data also includes find my car etc.  I think the car has its own link to Toyota rather than through home or mobile wifi.  My reasoning is a weak wifi connection in my garage but the data still appears in my app.

The car also has an alert button to contact Toyota Assist and I think that uses the same independent channel.

Link to comment
Share on other sites

4 hours ago, navger said:

New owner MY21 2.0 ts here with many questions!!

let's start with a basic one.

When phone is connected (android auto) with original usb cable (huawei) even though maps, phone  call, calendar etc are available and work ok so far the usb option configuration on the phone is stick to charge only. If I choose to media files trasfer if stays for a second and the comes back to charge only.

is this the reason why I still dont have any data in the "coaching" section. Everything is still 0!!!!

 

what am I doing wrong? I am lost, cause most of the guides/manuals dont explain this part...

hdrpl.jpg

Are you sure that your car has been connected to the Toyota servers by the dealer?

Link to comment
Share on other sites

 

My dealer insists that everything from his part is done correctly

I emailed Myt-europe two days ago, (since all values in hybrid coaching are still zero)  but no answer yet

 One thing is strange is that the completion status in profile and settings is  71% completed.  Is there something I must do to complete this ??

thanks for your replies

Link to comment
Share on other sites

navger I have a suspicion.  Can you start with the initial screen?  

When I open the App it starts with Dashboard.  It then displays the fuel state as a percentage.  The section below that shows car location.  Below that Car data with total mileage and then the car specification and finally car service overview.  Do you have fuel and mileage displayed correctly?

  • Like 1
Link to comment
Share on other sites


Roy,

No milage, no fuel!

Just a picture of  my car in dashboard and below my country's map in car location section but without a point of my car's location.😵

Link to comment
Share on other sites

Although I have a good bluetooth,  with tethering attach, I found that a cheap, mobile broadband wifi hotspot, seemed to sort my early issues with the app.

 

It also means that when I do reboot my phone, I don't have to remember to re enable bluetooth connection sharing. 

 

On the odd occasion the hotspot is totally off, I find the data connection from the car is shockingly poor via bluetooth tethering 

 

I don't know why they didn't just add a sim slot...again considering the price of the vehicle!

Link to comment
Share on other sites

AFAIK your bluetooth connection is only for a mobile/cell phone connection.  Your Wifi connection will not be normally through your phone unless you set that as the wifi source.  The phone wifi will be for the Android App and its feeds though the USB port.  As far as car connection and wifi my car is set up to use my home network.  It is not setup for public hotspots etc.  Never the less it will show its location, once stationery, whether my phone has been with the car of not.  This was the case when the garage took the car for service.

I believe the car has its own mobile connection for the emergency contact.  I am not sure if this remains a free service or whether you have to subscribe at some point.

Link to comment
Share on other sites

4 hours ago, Roy124 said:

Bingo.  Your car is not talking to the server.  The next thing to check is the entries in your car as it is clear that the problem is not the App.

Yes you are right.

I entered my phone number and now my profile is 100%complete. But still no data in the app. 

But what I must do in order to get the car send data to the servers? 

Please note that the car is MY21 and in the multimedia there is not the option 'toyota online' where I see in other posts that is the place the owner inputs his email address. In mine there is not such a option anywhere. (and the manual is not very helpful) 

Thanks Roy for your help!! 

Link to comment
Share on other sites

navger, given what you say about Toyota online, you may have to contact your dealer or hope a 21 model owner sees this.

Despite the lack of Toyota Online, Setup is your start point.  You need to setup your email address if you can find that option.  Then another ins Internet Auto connection.  I then have in Setup a WiFi connection.  I set WiFi power On, Access network On and connect to my network.  But I don't think this is exactly what you need.  It is the Toyota Online option and that may be buried in the settings.  Mine has an option icon that you say you don't have, however further in settings under that Internet Auto setting is a further Toyota online.

Until you get direct help, I suggest you browse all those setting options.

Link to comment
Share on other sites

Devon, there is much on those links that O do not recognise in my 2020 version.  I know I 'lost' my trip data until someone pointed me to the proper icons.  Now Toyota tell me that the App has not changed.  Either I had brain failure or the App indeed was updated. My version is 3.16.1(30089)

Link to comment
Share on other sites

navger, in Settings, Car, Location and Services, is Privacy Mode ON or OFF?

In Settings General look at Connected Services

Look at details, you will see that the Privacy mode will inhibit much detail.

Link to comment
Share on other sites

navger, the best way is to get your dealer to help, is that possible?

The next best is to sit in your car and have someone talk you through on your phone:

"Do this------what do you see?"

"Now press ------- what do you see?"

And of course they need to be familiar with the 2021 model.  

Also try Google - How do I activate my Toyota connect?

There are some possible things to work through.

Link to comment
Share on other sites

Thank Roy,

I just received an email from Myt support team. They confirmed that everything form the dealer in done correclty and they want some screen shots from the app

So I will reply to them and see how it goes!

Thanks again for your support!!

Link to comment
Share on other sites

  • 4 months later...

I know this is an oldish thread but wondered what the result was regarding navger's issue? I collected my new C-HR on Tuesday (five days ago) and have the exact same issue, no mileage, fuel percentage or car location on the front screen and no hybrid coaching option on the Services screen. The dealer set up the My T connection in the car during the handover.

Link to comment
Share on other sites

On 1/21/2021 at 10:57 AM, navger said:

Roy,

No milage, no fuel!

Just a picture of  my car in dashboard and below my country's map in car location section but without a point of my car's location.😵

I had a similar problem when they upgraded myT app about a year ago. I had originally installed the app when i got the car in mid 2019. At that time if i recall correctly it said to access all the data i had to contact the dealer to set it up which i did. After the dealer had set up their end they upgraded my phone app  but apart from a new phone screen layout there was still some data missing. After 1/2 hr of their "expert" trying to solve the missing data he said it was probably waiting for the server to update the data and to do a few trips before registering!!!!!!

After a few weeks still no joy so i uninstalled myT and then downloaded the app, installed it again and - hey presto. It worked including showing all trips since the visit to the dealer.

Hope that helps you.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership