Jump to content
Do Not Sell My Personal Information


Climate Control Matrix T27


Recommended Posts

My climate control Drivers side knob goes crazy and will only select Lo or up to 18. Seen a previous post thst the contacts need cleaning.

 

Can somone let me know how to remove don't want to scratch dash.

I have repaired washing machine motors put new lights on cd player's etc before so should be fine once i get going. Or do i need one of Ebay.

 

 

Link to post
Share on other sites

I did the fix many years ago, and you have to remove the two side panels, the radio and centre vents enough for access, the centre console around the gear level, again for access, then the ashtray with the heater control section. As I said, the radio and vents only need to be moved slightly for access. I used plastic trim removal tools. 
I had to unplugged the heater control unit, then dismantle it a little further to get at the contacts. 

This is so long ago, and I will need to see if I took any photos. The heater system has worked without issue up to now. 

Oh yes, I checked the temperature setting, and they go from Low to 16° then counts .5° to 29.5° then High.  

 

Link to post
Share on other sites
36 minutes ago, Konrad C said:

I did the fix many years ago, and you have to remove the two side panels, the radio and centre vents enough for access, the centre console around the gear level, again for access, then the ashtray with the heater control section. As I said, the radio and vents only need to be moved slightly for access. I used plastic trim removal tools. 
I had to unplugged the heater control unit, then dismantle it a little further to get at the contacts. 

This is so long ago, and I will need to see if I took any photos. The heater system has worked without issue up to now. 

Oh yes, I checked the temperature setting, and they go from Low to 16° then counts .5° to 29.5° then High.  

 

I went to my archive back up drives and found some photos.

Remove side trims 

P1140449.thumb.JPG.ec8f002961f07e45b36dc86dd63aa3ea.JPGP1140450.thumb.JPG.c3c8abc7cf4153a9210df25bec9bbf16.JPG654567074_P1140447(2).thumb.JPG.79e1daea1b7ac9b193a9e2fdecb83bc9.JPG 

Remove panels surrounding gear lever - then remove the ashtray 

654567074_P1140447(2).thumb.JPG.79e1daea1b7ac9b193a9e2fdecb83bc9.JPG

Lever the vent and radio surround, to separate from the heater control panel -  

P1140413.thumb.JPG.94163d38331fd9cf1da11ec755ff0297.JPG P1140408.thumb.JPG.87dc657979d219cba8a8276d1806cc33.JPG P1140439.thumb.JPG.915f39223c223da05f1d157492246ce0.JPG

Unplug the heater control - P1140440.thumb.JPG.74deb2c5984c027de4b8837e6f143438.JPG P1140417.thumb.JPG.1425ad0ea802c6072d82ef259b61caf5.JPG

To open the unit first use a T10 Torx bit to remove the screws -

P1140438.thumb.JPG.f911571921d2798664f5230b7737a391.JPG P1140419.thumb.JPG.6d1d5e9b1cf19d9b4eaddb27df0498e5.JPG P1140418.thumb.JPG.21046ea28b05a41f644a6363d688f62d.JPG

 

There are tabs around the edge - 

P1140437.thumb.JPG.0f4f47f9cf37b8c249a8202e5f31f5c0.JPG P1140436.thumb.JPG.28508c54e712025b1bdb5925d8d31ef0.JPG

 

The heater controls dismantled. 

 

 P1140426.thumb.JPG.ffa837b8a54a5aa872c654c7e7209970.JPG P1140421.thumb.JPG.5dc79b65fb7942d04703d956d9b0e3bf.JPG P1140423.thumb.JPG.3060823c928fbd561b07b6ca57f2c75f.JPG 

P1140422.thumb.JPG.48e3312ca6c8b36f2dcff9d81c90d47d.JPG P1140425.thumb.JPG.4e19fe8a42f9e02103f6526777028b3d.JPG P1140420.thumb.JPG.5c116819a187c64fe71e411c194bbb1e.JPG 

 P1140435.thumb.JPG.4f55c1a38e2ea505f20883c23064e2b0.JPG P1140430.thumb.JPG.62d33f6bc6d8d3b23cc40533adf61a66.JPG 

Sorry for the jumble of photos. I hope this helps.

P1140433.JPG

P1140410.JPG

P1140411.JPG

P1140412.JPG

P1140448 (2).JPG

P1140415.JPG

P1140429.JPG

P1140436.JPG

  • Thanks 1
Link to post
Share on other sites

Before you dismantle anything, its worth trying this first. With the ignition turned off, spin the temperature control knob really fast back and forth with your finger several times. Turn the ignition on to test it, and if its no better turn the ignition off and try the trick again. Our Avensis had this issue with the dirt in the control knob contacts causing the temp setting to stick or jump crazily, and doing the above 3 times or so seems to have cured it.

  • Thanks 2
Link to post
Share on other sites
  • 1 month later...

Konrad C. Thank you so much for taking the time and trouble to find the pictures it is appreciated and will be kept for reference 👍   But being a lazy sod, I took Yossarian247’s advice and turned the dial rather energetically and it worked 🤗🤗🤗  Thank you 🙏 

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership