Jump to content
Do Not Sell My Personal Information


Help needed problem radio rav4


Recommended Posts

 

hi all help needed

i have a Toyota rav4 2007 i bought an xtron centre consul about 2 years ago, it now seems that there is a fault the radio keeps draining  my Battery and even when i have switched it off it comes on by itself, does anyone know is there some sort of default setting that is making it do this as i am fed up keep jump starting my car i am in Torrevieja Spain

Link to post
Share on other sites

Sounds like you may have the permanent and ignition live wires crossed over. I would start here first.

Link to post
Share on other sites

Sounds like it a cheap Chinese android radio, if it's been fine up till now it's likely a faulty radio

If it's a standard double din it is $130 on Alibaba (custom fit one is $180) tbh, you get what you pay for

Link to post
Share on other sites
1 hour ago, satts67 said:

Sounds like you may have the permanent and ignition live wires crossed over. I would start here first.

we believe now it was fitted incorrect I have been on the xtron forum and they have given me the lowdown  so thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership