Jump to content
Do Not Sell My Personal Information


Glow plug light on dash


Recommended Posts

I have  57 plate avensis

When starting, the glow plug light literally stays on for s second, then goes out.

It's very difficult to start, especially on a cold day.

Please help

Link to post
Share on other sites

 

32 minutes ago, Wozza M said:

I have  57 plate avensis

When starting, the glow plug light literally stays on for s second, then goes out.

It's very difficult to start, especially on a cold day.

Please help

After 14yrs it probably needs a new one.

Link to post
Share on other sites

They need testing, no point in doing if that's not the problem, but certainly on age, and hard starting, it is the most likely solution. Non genuine are reasonably priced

Link to post
Share on other sites

Glow plug light on modern common rail dieses do not tend to stay on for long unless you are well below freezing. When you say difficult to start in what way?

  • Slow to crank, likely a Battery or starter motor issue
  • Normal crank but takes too long to fire, common on later #AD series diesel is a faulty Suction control valve SCV in fact there is a bulletin from Toyota.

EG-0132T-1110-EN

Subject: 1AD- FTV and 2AD-FTV Engine - Hard to start in cold condition

Models: AURIS, COROLLA, COROLLA VERSO, RAV4, AVENSIS

Model codes: ADE150, AUR10, ALA30, ADT250, ADT251

DESCRIPTION OF PHENOMENON Customer may complain about engine that is difficult (delayed) to start in cold condition but cranking speed is normal. For low cranking speed (< 200rpm) or no cranking, please follow the relevant diagnostic procedure in repair manual.

PRODUCTION CHANGE Improved design of the Suction Control Valve (SCV) to improve sliding performance and newly developed software to increase target fuel pressure in cold condition.

PRODUCTION CHANGE INFORMATION Not applicable, first generation AD engine is not produced anymore.

image.thumb.png.391c4e218f15606ed4b8597dd10be463.png

image.thumb.png.922a9346096693f9bf0ba677a3ec5e0c.png

image.thumb.png.0a47d7a72fe82efed9de010ee93a234f.png

 

Link to post
Share on other sites

Normal crank, turns over fine , just won't start. Takes me 5 or 6 attempts especially on a very cold morning

Link to post
Share on other sites
47 minutes ago, Wozza M said:

Normal crank, turns over fine , just won't start. Takes me 5 or 6 attempts especially on a very cold morning

So unlikely its Battery or starter, which leaves glow plugs (however they are monitored so a fault would normally keep the glow plug light on) or SCV.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership