Jump to content
Do Not Sell My Personal Information


Verso 2014 media Head


Recommended Posts

Hi there. I have a problem with the radio/CD/NAV unit in my Verso 2014. Has anyone seen/solved symptoms where the unit is dead, no power, so no radio or CD function, but screen is white(ie LCD backlight is on). Part number of the head is 86140-0f060. I am reluctant to buy a second hand head unit without SAT nav module, as i am not sure where the fault is. Any ideas?

 

Link to post
Share on other sites

Do you/did you have sat nav ? if so remove the radio and disconnect the cables that go to the nav module

or try disconnecting the Battery or removing the radio for 20 mins

Link to post
Share on other sites

Yup, sat nav module is connected. I will disconnect from head and see what happens. Odd that unit is dead, but backlight is on. Thanks, will give it a try and post back either way.

Link to post
Share on other sites

Ok, checked this again. Disconnected SAT nav module and cables. Head unit behaves the same. No button on/off response. Backlight on LCD display comes on after 15 secs aprox, but nothing on screen. removed front bezel from head without disconnecting anything and checked solder joints. Rectified some dry joints, but this has had no effect with regards to the fault.

Now looking at second hand head unit. My unit is a 86140-0f060. I have spotted a -0f061 but i dont know the difference presently.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership