Jump to content
Do Not Sell My Personal Information


Aygo Go Tom Tom sat nav screen not responding


Recommended Posts

Hi everyone, we have just bought a 2011 Aygo Go with the Tom Tom sat nav, it powers up fine and the map shows but touching the screen doesn't open any menus etc, it seems to be frozen, it hasn't got an sd card fitted so I don't know if that would make a difference, I've pressed the reset button for 20 seconds then powered it up but that didn't help at all 😞 , has anyone else had a similar problem?

Thanks ever so much. 

Link to post
Share on other sites

Release the tom-tom by the catch on the right, make sure the pin and contacts are clean

Did you do the reset by the pinhole in the bottom of the unit ??

Link to post
Share on other sites

Hi Flash22

Thanks for your help

I've just cleaned the pins and contacts and it's sadly still the same.

I did press the reset button in the bottom for 20 seconds with the unit switched off when I reset it the other day.

Neither of the buttons to the left of the unit (when in the car) seem to do anything either, the maps showing and has good gps signal/location.

We haven't got the SD card, does it need to be fitted to function do you know?

Thanks again

Paul

 

Link to post
Share on other sites

As a TomTom device it is supported by TomTom and may need updates or recovery you will need to install TomTom Home HERE and see if the unit responds

Link to post
Share on other sites

Ah, standalone TT. I have had that with a Garmin and a reset was required.  For SatNav help try PocketGPSWorld.com.  I had a quick browse and didn't find anything, but you could pose your own question.

 

Link to post
Share on other sites

Thanks for your replies Roy124 and Devon Aygo, Roy I was made aware of the issue by the dealer and the price I paid took it into consideration. I'll take a look at PocketGPSWorld, I have done a reset already, thanks.

Devon Aygo I'll install Tom Tom home this evening and see if that helps.

Does anyone know if you need to have an sd card fitted? I wouldn't have thought so as the map shows fine, but just in case!

Thanks again for your help

Paul

Link to post
Share on other sites

Paul, a couple of other points that might be relevant.  Does it know where it is?  If it has not been active for sometime its view of the satellites might be very different from the time it was last used.  The second, and also left field, is it might be in dead space.

I cannot explain the latter easily but it happened sometimes with my Garmin and always in the same area.  We would drive down to the cruise terminal at Southampton and in the vicinity of the docks it would simply freeze.  Happened about three times.  Never in precisely the same place but twice I had to do a reset and it only cleared once we were away from that area.

Of course it could be fried. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership