Jump to content
Do Not Sell My Personal Information


Engine tapping sound vvt valve?


Recommended Posts

Hi, so I have researched for quite a while now on this and other forums but I can't figure it out. Maybe somebody  has an idea.

My car: yaris XP13 hybrid 2015 with 150000km on it. 

Problem. 

When the car ist cold and I start the Engine everything sounds normal. After about 1 minute the engine starts to make a Metalic taping noise under a light load, once I release the padel it's gone, if I press it justst a little it's back. It does that till the engine reaches about 40-50 degrees. The noise is quite very audible inside the car and even louder outside. It sounds like it is coming from the valve area but who knows.. 

To be sure the vvt solinoid is clean I removed and checked it. It was clean. Then I took a picture of the valve housing which got me very worried. It looks like a part of the housing is broken off, but I can't find a reveeference picture on the internet to check. But it's hard to believe it's suppose to look like this ( rought edges etc.) 

Does it always look like that? Maybe somebody could check how it looks in their engine? Any ideas what the noise could be? 

 

Any help would be apriciated

WIN_20210421_19_41_08_Pro.jpg

Link to post
Share on other sites

I had a Fiat that was perfectly quiet when cold and when hot, but would tap a tappet while warming up. Saw it many years later, still doing the same.

Link to post
Share on other sites

It's got the wrong Oil in it, do an Oil a filter change iirc it should be 0w20

vvti solenoids don't tap, lifters do

  • Like 1
Link to post
Share on other sites

As it is heat related, the most likely is a drop in Oil pressure. I would follow Flash 's advice above.

Genuine Toyota filter, branded 0w-20 Oil to Toyota specification.

(removes one variable)

Link to post
Share on other sites

OK so the Oil is 0w20 liqui moly aa,

The filter is a mann filter wich I always considered to be very good. What is difrent on toyota filter? Can I get it in other places as the dealership? 

Link to post
Share on other sites

Does it do if the car is not in drive (just revving the engine) does it go away if you increase the RPM ? do you have a scan tool have a look at the Oil pressure

Link to post
Share on other sites

Not In P No, if so then veeerrry quiet.  It goes away at high revs above 3k. It does it in D if I press the breaks and then the gas at the same time (charging the Battery Manually) 

Link to post
Share on other sites

I don't know if you have driven auto's before, but you only drive an auto with your right foot only

Do not use the brake and throttle at the same time, the gearbox automatically charges the Battery it knows when to charge the Battery or when it needs to power the wheels with the electric motor or engine, all you are doing is causing damage

By holding the brake and revving it in drive you are going to kill the gearbox and the clutch (yes the hybrid has a friction plate in between the engine and gearbox)

Link to post
Share on other sites

I will try a toyota oilfilter and see if the noise changes, does this car have an Oil pressure sensor that can be read via obd? 

Link to post
Share on other sites

TBH you need a mechanics stethoscope to find the noise

Link to post
Share on other sites

Made an appointment at the dealer, unfortunalty first spot was the 18th of May. Hope it's nothing serious, really like the car. Will update if I have the solution 

Link to post
Share on other sites
6 hours ago, Mystralfire said:

Made an appointment at the dealer, unfortunalty first spot was the 18th of May. Hope it's nothing serious, really like the car. Will update if I have the solution 

Good man!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership