Jump to content
Do Not Sell My Personal Information


No bluetooth or sat nav


imnu
 Share

Recommended Posts

Hi all, my mum's 10yr old Yaris will no longer communicate with her phone and the sat nav won't load either.

When you go to the bluetooth section in the Touch and Go menu it is unresponsive. I deleted her profile but that didn't help. Additionally, when you hit the sat nav button, nothing happens. Radio, CD player and rear camera are fine.

I did enter the diagnostic menu and told it to run a test in the System Check option. I had to record the process on my phone because it flashed up the results too quickly to see what it says. In the first column it says OK and OK (in grey), nothing in the second column, and in the third it says Aux (in black). I was unable to hit the Memory Clr button because it only seems to give me milliseconds to do so.

When I went to check the software version in the menu, it just says DA, and on the line below, EXT BOX

I am hoping that the "stereo" is just stuck in a loop. If so, will disconnecting the Battery help? And if yes, how long does it need to be disconnected? I have no idea if there are capacitors that will need to discharge.

Thanks in advance.

Link to comment
Share on other sites


As above, it doesn't sound like the sat nav module is installed, which means the system is the basic Touch rather than Touch and Go.

Presumably it is an early 3rd generation - eg:

 

OIP.jpeg

Link to comment
Share on other sites

hi all,

thanks for the replies. I am pretty sure it did have sat nav. I will double check when I next speak to my mum.

For the record, this is what it looks like

 

 

20210314_143920.jpg

Link to comment
Share on other sites


The following post seems to suggest that the sat nav controls the BT. In the image shown, it says OK next to DA and EXT BOX. On my mum's it doesn't say OK. Am running late for work, but will follow the link in the link to see if I can find anything that helps when I have the time.

 

Link to comment
Share on other sites

  • 11 months later...

Do a mic check in the hidden service menu

Press and hold the music or car button and turn the sidelights on and off 3 times - Function test/settings

Do you have sat nav ?? Does it work ?

 

Link to comment
Share on other sites

It might help if the model was revealed. i.e. specification.

My Icon+ , certainly not a base version, has the same unit fitted, with a "Map" button, but it  doesn't have that that function from new. Touch, not Touch and go. Similarly, push "Map" nothing happens.

Mine does have dual climate control, as in the picture.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership