Jump to content
Do Not Sell My Personal Information


T Sport Corolla Cluster


Recommended Posts

T Sport Corolla 
Hey would anyone know why the gauges in the cluster would stop working/not lighting? Changed out the clutch and put gearbox back in. Put the 2 earth's back on the gearbox and plugged sensor in on top of the box, turned on ignition to find TRAC & VSC lights are staying lit & cluster won't light nor will anything read. I also gone a full stainless exhaust on the car but made sure to disconnect the Battery so I don't think that caused any issues. Any help will be appreciated. Thank in advance 👍

Link to post
Share on other sites

Sounds like a bad earth/ground check the Battery terminals are clean tight check the earth points on the chassis rail on the gearbox side

Anything else not working ?

Link to post
Share on other sites

No just the cluster is all, checked the earth that's on top of the box and the one that's one the side of the box. Is there anything else that I should check. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...




Forums


News


Membership