Jump to content
Do Not Sell My Personal Information


Toyota yaris keyless won't start


Hannah Martin
 Share

Recommended Posts

I have a 58 plate keyless entry and start 1.8 toyota yaris.

This has been an ongoing on and off problem for a couple months now. I get into the car with the clutch pushed down fully, the light goes green to indicate that it is registering the key fob, so I press the keyless start button and absolutely nothing happens. 

The first few times the car eventually started. Then I got to having to call out recovery, the guy rolled the car back a little and it started. The next few times this happened, I did the same and the car would eventually start. Then a little over a week ago I took it to my garage and they weren't sure what was going on as they couldn't diagnose the problem when it was working but we discussed the fact that the passenger door was locked shut and wouldn't unlock.

After being there and driving for about 20 minutes it happened again and would not start with the rocking the car, so recovery was called out again, (luckily the same guy so he had already seen the problem). He tested the Battery again and said it was fine. He tried to get the starter motor to engage but had no luck. Each time this has happened the steering wheel would lock too. 

The car was taken to my usual garage. They said that there had been a key fault so they cleared it and replaced the Battery in both key fobs. They said they were starting it several times a day (and driving it or leaving it running for a bit) and they hadn't had any problems so I picked it up yesterday. 

Well today it has once again not started. Exactly the same issue. Green light registering the key but absolutely nothing in response when I press the clutch and button. 

Has anyone else had anything like this? 

Link to comment
Share on other sites


have you tried starting it by pushing the start button with the fob ? . both my ssangyong and iq are keyless , and it does actually state to do that in the ssangyongs handbook in the event of a non start. done it a couple of times on that one but never needed it on the iq , toyota did supply me with a duff new 12v Battery once and that led to a few starting problems till they changed it . bestg i can do sorry.

Link to comment
Share on other sites

Stand on the clutch pedal next time and see if it starts - if so, the clutch switch may be worn, the garage maybe a bit more heavy-handed and push the clutch in that fraction more than you do

it will be the rear clutch switch, its a 15-min job to swap

Part number, 84520-42010

Link to comment
Share on other sites

Thank you both for replies. I have tried the fob on the push start and pushed the clutch down as far as I'm able to. I've had to get it taken to the Toyota dealership as it just will not start again. As soon as I have an answer from them I'll post an update so that if anyone else has this problem they'll hopefully have an idea of what it may be. 

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership