Jump to content
Do Not Sell My Personal Information


Touch 2 forgotten how to give directions


GregoryK
 Share

Recommended Posts

I have a 2017 Yaris with Touch 2 with Go.

Yesterday on the way home from Southampton to Gloucester, we noticed that the Sat Nav was no longer giving us directions. It tracked our current position on the map and kept this updated. It also displayed the helpful blue line to assure us that we were on the right route. But instead of saying, for example, turn right after 1.5 miles, the text at the bottom kept showing the name of our starting street and 0yd. Neither did it display the current speed limit for each stretch of road. We have tried changing the destination but to no avail.

Otherwise the console is working fine. We can still pick up the radio and we played an audio book through the USB port. But I am mystified by the device's sudden confusion.

Any advice or suggestions would be appreciated.

Link to comment
Share on other sites

  • 2 weeks later...

I had the same, but found that I had set the Nav volume off in error?
Not sure about the display at the bottom, as I rarely use the SatNav. Today was the first time in over a year. 😀

  • Like 1
Link to comment
Share on other sites

Here is an update on my situation.

1) I tried resetting my personal data on the device. This cleared the navigation memory and for my first journey the satnav worked as normal. It told me when to turn and updated the speed limit. However once I reached my destination, it defaulted to the error mode, whereby all I got was the blue line, no directions and no speed limit.

2) I downloaded the maps from Toshiba that my car came with. I transferred these to a USB drive and used this to reinstall the software. As with fix 1) it worked correctly for my very first journey. But then it immediately reverted to the error state.

Anyone else had a similar issue?

Link to comment
Share on other sites

2 hours ago, GregoryK said:

Here is an update on my situation.

1) I tried resetting my personal data on the device. This cleared the navigation memory and for my first journey the satnav worked as normal. It told me when to turn and updated the speed limit. However once I reached my destination, it defaulted to the error mode, whereby all I got was the blue line, no directions and no speed limit.

2) I downloaded the maps from Toshiba that my car came with. I transferred these to a USB drive and used this to reinstall the software. As with fix 1) it worked correctly for my very first journey. But then it immediately reverted to the error state.

Anyone else had a similar issue?

1) what "blue line"?

2) Huh?! Did you mean to say Toyota?

It sounds to me as if you have a physical fault with the GPS unit? (the module that is separate from the radio itself) Can you go into settings and tell us what version the radio firmware is? If I remember rightly it should start with "XExxxxx"? (it's a short number - not the great big long one. I had a Yaris Hybrid back in 2014 and another in 2017. Both of them needed an update to the head unit's firmware...

Link to comment
Share on other sites

On 9/5/2021 at 3:11 PM, WelshGasman said:

... as I rarely use the SatNav. Today was the first time in over a year. 😀

I tend to use it on long journeys whether I need it or not since it can sometimes provide useful options for if there has been an accident or some other obstruction ahead on the road...

Link to comment
Share on other sites


Toshiba was definitely a Duh moment.

Re the blue line: in normal operation, the satnav shows my current location, the blue line superimposed on the map indicates where I am going, and at the bottom of the screen it tells me how many miles to such and such a turn. In my current error state it still tracks where I am and displays the blue line but it doesn't give me the directions, neither on the screen nor as audio. All it displays at the bottom is the road I started from. If I miss a turning, the satnav does not redirect me and the blue line may well be off screen if I am on the wrong road.

It says that software version 6.7.owl and map id 2016v1. Is this what you mean or should I look for a different code.

Thanks

Gregory

 

Link to comment
Share on other sites

It's a different code? It's on the same page as the very long number which is your head unit's ID? I can't remember how to get to it now on that head unit but I'm sure that someone else will pop up... That's quite an old map version now - there has been a number of updates since that version and I seem to remember that the head unit's firmware gets updated at the same time usually? Is the car still within its 5 year warranty? If so, you may be able to get the dealer to update the head unit's firmware separately as a warranty claim?

Link to comment
Share on other sites

GPS must be ok as it's tracking your position.

It sounds like it's not starting the route. You are telling it to I assume, as it works first time.

Or maybe it's not ending the previous (first) route properly, though you'd think that would prevent it accepting a new one.

Either of those sounds like a possible faulty gate in a chipset, which would be a royal pain.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership