Jump to content
Do Not Sell My Personal Information


Heater fan control


Morgen85
 Share

Recommended Posts

Hello, just joined the forum after getting a Corolla T Sport. Really lovely car, just a couple of issues that I need to sort.

One problem is that the climate control works okay on automatic but on manual there's no control of the fan speed. Is it common for the switches themselves to break and are these available as spares?

The other problem with the HVAC is that hot air comes okay from the passenger side but it's cold on the drivers side. I gather this will be a problem with a blend door actuator. Anyone on here repaired a similar problem?

Any advice gratefully received!

Thanks,

Morgen

Link to comment
Share on other sites


Hi,

Is yours a Digital control panel ?  

Think a known problem is that the bars and gears linking the motors or the flaps can break, on ours you can see them from under the dash without having to remove anything or just the very lower cover that goes around the pedals.

Also read that the flap can  become disconnected from its rod, so everything seems to be working externally, but inside the box its just not being moved.

Link to comment
Share on other sites

9 hours ago, oldcodger said:

Hi,

Is yours a Digital control panel ?  

Think a known problem is that the bars and gears linking the motors or the flaps can break, on ours you can see them from under the dash without having to remove anything or just the very lower cover that goes around the pedals.

Also read that the flap can  become disconnected from its rod, so everything seems to be working externally, but inside the box its just not being moved.

 

Thank you. I've had a look at the servos on the drivers side under the dash and they seem to move through the full range of motion and open and close the flaps they are connected to. I've also tried manually unhooking the servos and moving the flaps myself and the problem remains the same - cold on one side, hot on the other.

 

I've heard that this could be due to a blocked heater matrix.

 

It is a digital control panel. From what I can tell I have two problems with the HVAC; a broken control panel and possibly a blocked heater matrix. I'm trying to source a control panel to try that out. I also thought I'd see if Toyota still sell them but I'm guessing the price will be prohibitive!

 

Cheers,

Morgen

 

 

Link to comment
Share on other sites

Hi,

Do not know if the Tsports air con is any different from the others, but this may help.

First there is this simple diagnostic you can run on the Digital panel that might show an error.

You do not mention anything about the air con and if it deliverers cold air evenly to both sides?

If the heater matrix was blocked would have thought it would be cool on both sides ? but not saying it could not happen !

If you do a search in this Corolla forum you will find  a very long post about blocked heaters and several methods fork used that more than often cleared things.

Though not  UK spec this US pdf should give you some guidance of where and how the cores are located.

 

 

 

000793.jpg

55 - HVAC.pdf

Link to comment
Share on other sites

6 minutes ago, oldcodger said:

Hi,

Do not know if the Tsports air con is any different from the others, but this may help.

First there is this simple diagnostic you can run on the Digital panel that might show an error.

You do not mention anything about the air con and if it deliverers cold air evenly to both sides?

If the heater matrix was blocked would have thought it would be cool on both sides ? but not saying it could not happen !

If you do a search in this Corolla forum you will find  a very long post about blocked heaters and several methods fork used that more than often cleared things.

Though not  UK spec this US pdf should give you some guidance of where and how the cores are located.

 

 

 

000793.jpg

55 - HVAC.pdf 1.35 MB · 1 download

Thank you for this, I'll have a proper look through it.

 

The air con works very well - ice cold, then when I turn the heat up the passenger side vent gets hot. The manual fan control doesn't work at all so the fan speed only changes when I alter the temperature on automatic mode.

 

I agree regarding the heater matrix; seems surprising to me that a blocked one world leave one side of the car working the way mine does. There's a video online I found today though of an owner with this problem managing to flush the matrix and resolving the problem. That would still leave me with the broken control panel, though.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership