Jump to content
Do Not Sell My Personal Information


2016 1.6 Avensis broke down need help with codes


clarke4104
 Share

Recommended Posts

Hi I have a 2016 1.6 Avensis touring sport model WWT270R with 146000 miles which I have owned from it was 6 months old and have used as a taxi since. It has been fully serviced every 10000 miles with original Toyota parts with my local independent garage since I’ve bought it. My problem is it stopped after about 2 hours into a shift with no prior warning. I have the following codes if someone has had any experience of this, P1094 rail pressure below threshold during start, P1474 jammed valve during offset learning, P0087 fuel rail/ system pressure too low.I can confirm I’m getting diesel up to the fuel filter and cracked fuel line to No1 cylinder which does not appear to be getting fuel. Any help would be greatly appreciated.

Link to comment
Share on other sites


P1474 is related to the intake swirl valve(s)

Have you filled up recently ?

Check the resistance of the swirl control valve, it should be 22-42 ohm

1272393974_1wwswirlcontrolvalve.thumb.jpg.e6c4a2249f1c48d19b21a028ab9e5c7c.jpg

it's located on the left of the intake as you look at the engine

Link to comment
Share on other sites

Thanks Bob for the reply, yes I did put £30 diesel in that morning before I started work, I always use the same BP filling station beside me, why do you ask is there a connection and can this trigger the other codes (sorry I dont know the function of the SCV), I will not be able to do this check until tomorrow.

Link to comment
Share on other sites


9 hours ago, clarke4104 said:

Hi I have a 2016 1.6 Avensis touring sport model WWT270R with 146000 miles which I have owned from it was 6 months old and have used as a taxi since. It has been fully serviced every 10000 miles with original Toyota parts with my local independent garage since I’ve bought it. My problem is it stopped after about 2 hours into a shift with no prior warning. I have the following codes if someone has had any experience of this, P1094 rail pressure below threshold during start, P1474 jammed valve during offset learning, P0087 fuel rail/ system pressure too low.I can confirm I’m getting diesel up to the fuel filter and cracked fuel line to No1 cylinder which does not appear to be getting fuel. Any help would be greatly appreciated.

tbh  servicing it with genuine toyota parts aint worth a dam as thats one of those engines with the dreaded bmw engines 

Link to comment
Share on other sites

Just an update, checked the SCV as previously suggested and resistance within spec30 ohms, removed the camshaft sensor and can see the camshaft pulley turn so would suggest the chain is intact. I said on initial post that I checked the diesel filter and it was full of fuel could the pump in tank still be suspect and how best to check this. Thanks 

Link to comment
Share on other sites

Just an update, car sorted and back up running. Problem was in tank fuel pump had seized, unit replaced part number as previous post 7702005150, fuse for the system also replaced think it was fuse no. 33 below the glove box. Thanks for all help and inputs.

  • Like 3
Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership