Jump to content
Do Not Sell My Personal Information


No hi beam RAV4 G1 jap import


davev8
 Share

Recommended Posts

Have no high beam. car is Rav4 G1 jap import. if i switch to hi beam it dont work but the blue indicator on the dash lights up  i have dip fine and if i pull the stork back to flash then high beam will come on...which makes me think all wiring is fine and is a relay problem ..all fuses are ok

The main relay is working fine this is just an on or off relay not a change over, if i pull it out i lose every thing as in no dip and no high beam when i flash ..so there must be another relay to change over from dip to beam but i can not find it    a useful site here    https://fuseandrelay.com/toyota/rav4-1g.html do indead show another relay in the relay box   that they marked B and call   Headlamp switching relay  so that sounds like what i am looking for BUT my  car dont have one just an empty space without even a socket  so i am at a loss..somewhere some place there is a means of switching from dip to beam most probably with a relay ..i have listened for a click of a relay as the wife flash hi beam but not find anything  SO any ideas        

Link to comment
Share on other sites


Sorry David currently 139 people have read your post and obviously no one has been able to help, on this forum if anybody could help they would be posting info.

Link to comment
Share on other sites

Hi

Bit of guessology but could this be a problem within the computer set up.

Is it worth having the car plugged in at a garage and checked out.

only other thing is that it could be a fault in the stalk as I assume that you pull back to flash the lights but push forward to go to high beam. Possibly worth getting an auto electrician to check it out.

Just trying to help

regards Terry

 

Link to comment
Share on other sites

I suppose that is the down side of having a (generally) very reliable car - some faults can just be a curve ball with no history.

Hope you get a solution soon.

Link to comment
Share on other sites

On 3/26/2022 at 8:51 AM, Terry10 said:

it could be a fault in the stalk as I assume that you pull back to flash the lights but push forward to go to high beam. Possibly worth getting an auto electrician to check it out.

I can't see it being a 'computer' fault in a car from the last century, but, as Terry suggests, you ought to check out the stalk, switches and connectors if you haven't already.

Then, I guess, it's a question of tracing back through the wiring loom. As you have already implied, the high beam switching wires really must run back to the associated relay ...

Link to comment
Share on other sites

On 3/27/2022 at 12:24 PM, philip42h said:

I can't see it being a 'computer' fault in a car from the last century, but, as Terry suggests, you ought to check out the stalk, switches and connectors if you haven't already.

Then, I guess, it's a question of tracing back through the wiring loom. As you have already implied, the high beam switching wires really must run back to the associated relay ...

yes i think tracing back is the only thing left 

i think the stalk is ok  (but i will check it )as when i put it in to high beam position the blue high beam warning light comes on, on the dash. also if a pull the stalk back to flash position high beam will come on with dip...if i pull out the main head light relay nothing works ...i am pretty sure its a changeover relay at fault  as it must have one to change it over from dip to beam..its just my car its not where it should be ...maybe different as a jap import..i should get i bit of time for another look tomorrow..worst case i will rewire it with my own wiring ...as it will be pre canbus..i have done this before putting a fresh supply to i switch and then to a floor mounted Lucas dip/beam switch as fitted to 1960s land rovers and other cars...

just would be less work if some one knows where the relay is

its been a reliable car had it about 4 or 5 years and its only had 2 Wiper Blades and bulb for the MOTs

its the most fun car i have had in the snow with its 4x4 system from a celica GT4 with a rear wheel bias rather than other small 4x4 that are really just FWD and the back drives when needed 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership