Jump to content
Do Not Sell My Personal Information


Loss of power on my Avensis


Devontony
 Share

Recommended Posts

Hi guys 

I have a 2008 Toyota Avensis that has lost power. I am convinced its something to do with the turbo. Before I lost power every time I changed gear it sounded like an Owl, no joking honestly. I don't know how to identify what engine I have too? I put in my reg number on auto data and it comes up with a cambelt kit and a timing chain kit, now I know it doesn't have both. 

Please can you give me some advice please? 

Link to comment
Share on other sites


10 hours ago, Devontony said:

Hi guys 

I have a 2008 Toyota Avensis that has lost power. I am convinced its something to do with the turbo. Before I lost power every time I changed gear it sounded like an Owl, no joking honestly. I don't know how to identify what engine I have too? I put in my reg number on auto data and it comes up with a cambelt kit and a timing chain kit, now I know it doesn't have both. 

Please can you give me some advice please? 

i know yours is the older version but maybe something like this is needed 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership