Jump to content
Do Not Sell My Personal Information

Android auto - no microphone


Recommended Posts

Any suggestions welcome - I can connect to AA normally with USB under the screen, and I get the small pop up when getting WhatsApp messages etc, but it won't read them out, nor will the car respond to "hey Google" etc. The Google assistant microphone icon in the corner is sort of greyed out. 


Likely to be the car or my phone? (I don't have an alternative android phone in the house to test this with. The wife has iPhone) 

Link to comment
Share on other sites

I think that is a phone setting. I remember seeing something about messages displayed on the car screen so I tried the setting on my phone. I found it very irritating so turned the setting off, I have an iPhone, the setting was in bluetooth/devices/car multi media/show notifications. I am sure yours will be similar 

Link to comment
Share on other sites

I’ve not got the ‘hey google’ to function but usually press the steering wheel button and then the function is displayed for me to speak. There is I think an on screen button but not convenient.

I can get text messages to show if I’m not in AA but no when it’s functioning. Frankly I’m not so bothered as I find them a distraction when I’m driving even when it’s spoken you need to press buttons to get a reply? Or maybe that’s just the way I’ve set things up.

Link to comment
Share on other sites

Very difficult to diagnose these things as it could be a whole manner of different causes and it's often trial and error. It does sound like it's phone settings rather than multimedia settings though but it sounds like multiple different issues 

Here's a few general things you could try.....

There is a lot of posts on the internet about messages not being read out. This is supposed fixed. May sure you have the latest version of AA and messages app installed.

Find the AA app on the phone, long press and select app info. In Storage, clear the Cache. In permissions, check access is granted to everything (especially microphone).

Either go into the app, or go to settings and search for Android Auto. Make sure use OK Google is enabled. Check other preferences are as you want them while you're there.

If all else fails, either uninstall the app and connect to the car to reinitiate the set up, or forget the connection to your car and do the same (the former should give a cleaner install but might not be possible depending on your phone and whether the app is there as a standalone or embedded in the background)

One of the workarounds suggested for the read out of messages was to check the text to speech settings in settings->accessibility has the Google engine enabled. You could try that also.

  • Thanks 1
Link to comment
Share on other sites

Thanks for help. I tried all the suggestions, and whilst they didnt work, they lead me to look in the right place - my phone had disabled the central Google app itself! I think I have turned on a feature to disable apps that I haven't used in a long time, and because everything has Google integrated, I've not had a reason to open the main Google app itself. Or at least that's my working theory. 


Much obliged 👍

  • Like 3
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...