Jump to content
Do Not Sell My Personal Information


Aygo hazard switch


Recommended Posts

Hi, new member, this might have been answered somewhere ... should the hazard switch flash in a 2010 Aygo?

Thanks.

Link to comment
Share on other sites


I don't think so, they're usually backlit, so you can see them in the dark yes they are a common failure

random pic off the forum

Hazard.jpg.8dfde14415cb3866c16bdb45f0f65

Link to comment
Share on other sites

3 minutes ago, flash22 said:

I don't think so, they're usually backlit, so you can see them in the dark

Thanks,  the problem is actually the left turn indicator arrow not working.   That won't be an MOT fail as the 'tick' works but it will fail on the hazards as they should both flash indication, hence my question on the button,  if that should flash then it would be ok ... time to take the binnacle off ...

Cheers

Link to comment
Share on other sites

2 hours ago, flash22 said:

If the indicators work on the car, It's either the power, ground or the led that has died

https://andydoz.blogspot.com/2016/08/citroen-c1-mk-1-peugeot-107-toyota-aygo.html

Thanks, looks perfectly straightforward ... 😉 The £75 that https://www.sancarsauto.com/products/toyota-aygo-instrument-cluster-repair-service?variant=39615287033905 want looks cheap ... Anyone on here ever used these folk or similar?

Cheers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership