Jump to content
Do Not Sell My Personal Information


Navi chip problems


Recommended Posts

Two button I’ve managed to sort it but now the screen just comes up with a picture of a SIM card with a orange cross and an exclamation mark 

Link to comment
Share on other sites

Moved to the Aygo forum.

The Aygo sat nav was an additional module (X-Nav) rather than software.

Thought the X-Touch in the post facelift Aygo was no longer compatible with the X-Nav as the three button X-Touch has Android Auto/Apple Carplay.

Link to comment
Share on other sites

Thanks for your replies much appreciated last reply has lost me a bit the sat nav worked fine up to a few days ago took the little sd card out today and gave  it a clean but still didn’t work will this be a trip back to Toyota to sort this in your opinion 

Link to comment
Share on other sites

Take the card out and give it a clean, only remove or replace the card with the ignition off, if you have a card reader see if a pc will read the card you may also want to check the fuse for the nav that is behind the radio

the X-nav was still an option up to late 2019

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership