Jump to content
Do Not Sell My Personal Information


Poor performance


craig83
 Share

Recommended Posts

I've recently acquired a 2005 avensis wagon, 2ltr vvti in immaculate condition, it has 180000 miles on it but looks brand new, my only gripe is I don't think it performs as good as it should. I know it's high milage but its been well looked after with a full service history. I've changed the air filter, removed and cleaned the throttle body as it was caked in carbon crud but that's made no difference and it had a fresh oil flush and change. It idles at or below 600rpm as well which I think is a bit on the low side. Would it be the vvti solenoid that I should look at next, either clean it or replace it as when I put my foot down, nothing much happens. I'm not expecting super car performance but a 2 ltr should still have some punch! Any ideas welcomed!

Link to comment
Share on other sites


The 1AZ engine is very complicated having a direct injection. This means there is a high pressure fuel pump and it is possible that it may not be performing well. Also the injectors themselves may have issues. They may need cleaning. Basically checking the fuelling. Still check the vvti. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership