Jump to content
Do Not Sell My Personal Information


Yaris Touch and Go satnav where to get code


Recommended Posts

I need to replace the Touch and Go unit in my 2012 Yaris but the replacement unit is unlikely to be supplied with the code to activate the satnav.

Does anyone know if this code is available from Toyota dealers if I provide the serial number of the unit, and if so if there is a fee for them to provide it? 

Also is an additional code needed for the radio part of the unit as well?

Many thanks

Link to comment
Share on other sites

There is no code, its plug and play, the only time you need a code is when the map is updated, and you get that with the map purchase

Link to comment
Share on other sites

4 hours ago, flash22 said:

There is no code, its plug and play, the only time you need a code is when the map is updated, and you get that with the map purchase

Thanks, so a suitable replacement unit from say eBay would have the satnav feature already loaded onto it? 

Link to comment
Share on other sites

1 hour ago, Charlie28 said:

Thanks, so a suitable replacement unit from say ebay would have the satnav feature already loaded onto it? 

The display head unit and navigation are separate items, what issues are you getting?

Link to comment
Share on other sites

1 hour ago, Devon Aygo said:

The display head unit and navigation are separate items, what issues are you getting?

Nothing happens when the map nav button is pressed and bluetooth is not working (as well as the phone buttons on steering wheel). Radio is fine. Auto electrician says bluetooth module has broken.

The item I've been looking into is product code 86140-0D020 which I thought was the display header unit with the nav and bluetooth module integrated into it? Or is that not the case? 

Link to comment
Share on other sites

Touch is the display (DA), GO is the nav module that bolts underneath it

http://www.toyota-tech.eu/aimuploads/{32348A0F-FC7E-DE46-0D5A-52AB12FFFC7E}/Yaris_Touch_and_Go_RHD_PZ490_00331_00_AIM_002_218_2.pdf

example of the early touch nav module

https://www.ebay.co.uk/itm/284815574093

 

remove the radio and unplug the nav module wait 10 mins and plug it back in

 

as a stop gap remove the radio and unplug the nav module 2 cables and move the square grey usb connector from the nav module to the radio

 

 

Link to comment
Share on other sites

On 7/4/2022 at 9:17 PM, Charlie28 said:

Nothing happens when the map nav button is pressed and Bluetooth is not working (as well as the phone buttons on steering wheel). Radio is fine. Auto electrician says Bluetooth module has broken.

The item I've been looking into is product code 86140-0D020 which I thought was the display header unit with the nav and Bluetooth module integrated into it? Or is that not the case? 

OK both the DA (Display audio) & MEU ( Media extension unit/Nav ) contain bluetooth units which can work independently in the DA when there is no MEU or together when joined, if either has failed then they can stop the bluetooth and cause other operational issues.

First port of call would be to disconnect the MEU using the guide Falss22 has posted, just disconnect the leads linking DA to MEU and move the USB plug back to the DA, disconnect the Battery to reboot the DA and reconnect the Battery, on start up you may have to repair the bluetooth if the DA now works then your MEU is faulty if not then your DA is faulty.

Link to comment
Share on other sites

5 hours ago, flash22 said:

Touch is the display (DA), GO is the nav module that bolts underneath it

http://www.toyota-tech.eu/aimuploads/{32348A0F-FC7E-DE46-0D5A-52AB12FFFC7E}/Yaris_Touch_and_Go_RHD_PZ490_00331_00_AIM_002_218_2.pdf

example of the early touch nav module

https://www.ebay.co.uk/itm/284815574093

 

remove the radio and unplug the nav module wait 10 mins and plug it back in

 

as a stop gap remove the radio and unplug the nav module 2 cables and move the square grey usb connector from the nav module to the radio

 

 

 

14 minutes ago, Devon Aygo said:

OK both the DA (Display audio) & MEU ( Media extension unit/Nav ) contain Bluetooth units which can work independently in the DA when there is no MEU or together when joined, if either has failed then they can stop the Bluetooth and cause other operational issues.

First port of call would be to disconnect the MEU using the guide Falss22 has posted, just disconnect the leads linking DA to MEU and move the USB plug back to the DA, disconnect the battery to reboot the DA and reconnect the battery, on start up you may have to repair the Bluetooth if the DA now works then your MEU is faulty if not then your DA is faulty.

Thank you both, so what you have described is a way of eliminating which bluetooth unit (DA or MEU) is at fault and can then work out which part I need to replace. The auto electrician who looked at it initially did seem to do similar things to what you described so will ask him initially whether he managed to narrow it down to a fault with the DA or MEU 

Link to comment
Share on other sites

When you install the nav module (MEU) it disables the USB and bluetooth inside the DA, and it uses its own onboard BT and USB

you can go into the hidden service menu and run a systems check and post the results here

Press and hold the car button, then turn the lights on and off 3 times - tap Failure diagnosis - wait about 30-60 sec for it to run its tests

Link to comment
Share on other sites

21 minutes ago, flash22 said:

When you install the nav module (MEU) it disables the USB and Bluetooth inside the DA, and it uses its own onboard BT and USB

you can go into the hidden service menu and run a systems check and post the results here

Press and hold the car button, then turn the lights on and off 3 times - tap Failure diagnosis - wait about 30-60 sec for it to run its tests

Thanks. Just tried this but I'm getting a glitchy screen that doesn't seem to be doing anything after a good 5 mins. Hopefully you can see attached video. 

 

 

Link to comment
Share on other sites

The DA is dying IMO. Try a soft reset (press and hold the power button for 10 seconds), let it reboot and try again

Link to comment
Share on other sites

1 hour ago, flash22 said:

The DA is dying IMO. Try a soft reset (press and hold the power button for 10 seconds), let it reboot and try again

Tried this but nothing happened when I pressed and held the power button. Failure diagnosis screen still glitching. Does this mean more likely to be a faulty DA? 

Link to comment
Share on other sites

41 minutes ago, flash22 said:

i would think so

there are plenty on eBay from £40 up

Thanks for your help. So would you replace the DA first, then see if that sorts the nav and BT issues, and if not I'll need to replace the MEU as well? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership