Jump to content
Do Not Sell My Personal Information


Yaris Engine Headaches & Nightmares


Recommended Posts

Hi All,

Im in search of advice of my recurring nightmare... HHHELPP!!!

No the truth is, ive got an old yaris 1.0 vvti 2003 that had a rattling timing chain, so after running it to work and back after a month or so, like an idiot.. it gave up on me. So after getting it checked out by a mechanic, i decided to buy a second hand engine, not knowing about the various engine versions for that car. I was happy enough when the guy i bought it off quoted that it was a 1SZ engine. Cut a longgggg story short i fitted the replacement engine to find that the camshaft sensor (2-pin) wont fit the wiring loom (3-pin) thats fitted in the car... Ive swapped the sensors around from old engine but when i turn it over ive got no spark or feul to the injectors. Is there a work around for this problem ? So i believe my original engine was the French Build and my doner engine is the Japanese ?

Thanking You,

Chris

Link to comment
Share on other sites


Do you have a pic of the new engine ? did you change over the engine wiring loom as 2003 is a changeover year

 

I will send you a PM

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership