Jump to content
Do Not Sell My Personal Information


Corolla E210 Repair - please help :(


Recommended Posts

Hi,

I am in dying need of some help. I'm repairing my Corolla Hybrid Estate e210 (was hit on the front driver side corner). I've replaced headlight, washer bottle and parking sensors including loom, however, I still have ABS fault (brakes feel stiff), PKSB fault and pre collision fault on the dash. Some of the wiring was damaged going into the headlight and although I have everything working there is one green wire which i have no idea where it goes! 

My question:

1) I have heard I can reset PKSB on techstream by going into ECU reprogramming - anyone have any idea how to do this?

2) Are there any repair manuals available for this car ideally a wiring diagram (i can't find anything online)

Thanks in advance

IMG 6.jpg

IMG 5.jpg

IMG 4.jpg

IMG 3.jpg

IMG 2.jpg

IMG 1.jpg

Link to comment
Share on other sites


3 minutes ago, kh4n88 said:

 

2) Are there any repair manuals available for this car ideally a wiring diagram (i can't find anything online)

 

 

 

 

 

 

 

 

Register here & the wiring diagrams are in the chargeable part of the website.

Toyota-Tech.eu

 

  • Like 1
Link to comment
Share on other sites

Thanks guys, has anyone been able to reset the PKSB sensors using techstream (apparently it can be done in the ECU menu) instead of paying toyota £120 or so.

 

Link to comment
Share on other sites

what wire, and what location ?

brake low power - is to do with the electric vacuum pump/accumulator - they some times blow a fuse or blow a vent

yes, you need to reset any codes to clear the messages

Link to comment
Share on other sites

1 hour ago, flash22 said:

what wire, and what location ?

brake low power - is to do with the electric vacuum pump/accumulator - they some times blow a fuse or blow a vent

yes, you need to reset any codes to clear the messages

So its a big wiring loom and wires come out of it for the headlight, washer bottle and various other bits. In the part where everything is coming out for the headlight there is a dark green wire which i can't for this life of me figure out where it is going! i ordered techsteam so going to try to run some detailed codes 

thank you for the low brake power guidance i'll have to look into that. Hoping techstream tells me more finger crossed!

Link to comment
Share on other sites

ok what doesn't work on the headlight ? high beam ? DRL ?

Having a look at wiring diagrams, dark green is high/low DRL either pin 4 (led) or pin 2 (halogen)

Link to comment
Share on other sites

2 hours ago, flash22 said:

ok what doesn't work on the headlight ? high beam ? DRL ?

Having a look at wiring diagrams, dark green is high/low DRL either pin 4 (led) or pin 2 (halogen)

The location is on the driver side the thickest loom that comes down. all the wires from this split and go into the headlight and everything seems to work (except for the 3 little circular LEDs in the headlight on either side but i'm not getting a fault on the dash and not sure how to work these). all beams work and DRL seems to work 😕

i'm not sure if this wire is important for the other issues i have on the car or just a red herring and i can leave it. i opened up some of the other looms but can't find the other end of this wire annoyingly!

IMG 1.jpg

Link to comment
Share on other sites

1 hour ago, flash22 said:

On the grey 6 pin plug on the headlight you should have a Light green, Black, White with black stripe, Pink and a Red

Yep thats correct, i managed to connect all that up and get the headlight working but there is a lingering single dark green wire which I can’t for the life of me work out where it goes!

Link to comment
Share on other sites

I would strip back the corrugated tube, it should be colour to colour, any joins are inside the car, from the diagram it looks like it goes over to the left-hand headlight (is the left working correctly ??)

Link to comment
Share on other sites

1 minute ago, flash22 said:

I would strip back the corrugated tube, it should be colour to colour, any joins are inside the car, from the diagram it looks like it goes over to the left-hand headlight (is the left working correctly ??)

Yeh headlights seem to be working fine, i opened up some of the corrugated tubes in the area to find the dark green wire but could not find the other end of it. I think i need to spend an extended period of time and open up all the corrugated tubes to see if i can find it.

Do you know how to turn on the 3 circular led's in the headlight? they are the only things that didn't turn on when i was checking it yesterday but i don't have an error on the dash to say there is a fault with them

s-l1600.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership