Jump to content
Do Not Sell My Personal Information


Lc4 B9003 Sat-nav Retro Fit


SoftRoader
 Share

Recommended Posts

Just fitted the b9003 full screen sat-nav to my LC4 Land Cruiser; it originally came with the TNS300 with ETA system but I decided to swap it out for the AISIN B9003 full screen version.

So far so good but I've got a few issues...

1. Managed to find out which wire the "reverse" signal was on so with my Pioneer rear view camera when put into reverse the screen changes to the rear view camera...GOOD...Wait...no image, I assume this is because there is no power going to the camera (I've used all the connections on the 4 pin connector ont the back of the B9003 i.e. 2 for the camera and two for +ve power and ground. When in reverse the screen displays the usual "Check Your Surroundings" message but no image. So it is registering when in reverse, but it's not displaying any image from the camera. Might try taking power from the reverse lights...pain!

2. Can identify the parking (hand) brake signal too

3. CAN'T identify the speed signal, the TNS300 doesn't seem to come with one, it only seemed to come with 2 inputs (reverse & hand-brake) both of these inputs have been confirmed via the diagnostic mode on the B9003...does anyone know where I can get the speed signal from, I can't believe that the TNS300 doesn't use the speed signal but I can't for the life of me find it!

My Land Cruiser is in bits and needs the forums help!

Link to comment
Share on other sites

  • 2 weeks later...

Just fitted the b9003 full screen sat-nav to my LC4 Land Cruiser; it originally came with the TNS300 with ETA system but I decided to swap it out for the AISIN B9003 full screen version.

So far so good but I've got a few issues...

1. Managed to find out which wire the "reverse" signal was on so with my Pioneer rear view camera when put into reverse the screen changes to the rear view camera...GOOD...Wait...no image, I assume this is because there is no power going to the camera (I've used all the connections on the 4 pin connector ont the back of the B9003 i.e. 2 for the camera and two for +ve power and ground. When in reverse the screen displays the usual "Check Your Surroundings" message but no image. So it is registering when in reverse, but it's not displaying any image from the camera. Might try taking power from the reverse lights...pain!

2. Can identify the parking (hand) brake signal too

3. CAN'T identify the speed signal, the TNS300 doesn't seem to come with one, it only seemed to come with 2 inputs (reverse & hand-brake) both of these inputs have been confirmed via the diagnostic mode on the B9003...does anyone know where I can get the speed signal from, I can't believe that the TNS300 doesn't use the speed signal but I can't for the life of me find it!

My Land Cruiser is in bits and needs the forums help!

1. I've fitted one to my RAV, first up yes sound like you've connected up the reverse sensor OK, all this does is to supply a +12v signal to the head unit to notify that the car is in reverse usually taken from the reversing light circuit, you have 2 choices with the camera no one is sure about the output voltage coming from the head unit but its not +12volts and most aftermarket camera's require 12v, so you can either permanently power the camera ( wish I had done that) or take the supply from the reversing lights so you have to wait a second or two for the camera to powerup.

2. The handbrake sensor (someone may correct me if I'm wrong) is for stopping the Sat Nav destination from being entered whilst moving,this is a requirement for the US market so I would bother connecting it.

3. I didn't need to connect the speed signal in the RAV if it has the standard 10way & 6 way block connectors you might find its part of the loom, when you first install the NAV you might find it takes sometimes upto 1/2 hr before the system finds itself ( make sure the antenna is not too restricted though)

If you need any connector diagrams or diag manuals just PM me.

:thumbsup:

Link to comment
Share on other sites

Just fitted the b9003 full screen sat-nav to my LC4 Land Cruiser; it originally came with the TNS300 with ETA system but I decided to swap it out for the AISIN B9003 full screen version.

So far so good but I've got a few issues...

1. Managed to find out which wire the "reverse" signal was on so with my Pioneer rear view camera when put into reverse the screen changes to the rear view camera...GOOD...Wait...no image, I assume this is because there is no power going to the camera (I've used all the connections on the 4 pin connector ont the back of the B9003 i.e. 2 for the camera and two for +ve power and ground. When in reverse the screen displays the usual "Check Your Surroundings" message but no image. So it is registering when in reverse, but it's not displaying any image from the camera. Might try taking power from the reverse lights...pain!

2. Can identify the parking (hand) brake signal too

3. CAN'T identify the speed signal, the TNS300 doesn't seem to come with one, it only seemed to come with 2 inputs (reverse & hand-brake) both of these inputs have been confirmed via the diagnostic mode on the B9003...does anyone know where I can get the speed signal from, I can't believe that the TNS300 doesn't use the speed signal but I can't for the life of me find it!

My Land Cruiser is in bits and needs the forums help!

1. I've fitted one to my RAV, first up yes sound like you've connected up the reverse sensor OK, all this does is to supply a +12v signal to the head unit to notify that the car is in reverse usually taken from the reversing light circuit, you have 2 choices with the camera no one is sure about the output voltage coming from the head unit but its not +12volts and most aftermarket camera's require 12v, so you can either permanently power the camera ( wish I had done that) or take the supply from the reversing lights so you have to wait a second or two for the camera to powerup.

2. The handbrake sensor (someone may correct me if I'm wrong) is for stopping the Sat Nav destination from being entered whilst moving,this is a requirement for the US market so I would bother connecting it.

3. I didn't need to connect the speed signal in the RAV if it has the standard 10way & 6 way block connectors you might find its part of the loom, when you first install the NAV you might find it takes sometimes upto 1/2 hr before the system finds itself ( make sure the antenna is not too restricted though)

If you need any connector diagrams or diag manuals just PM me.

:thumbsup:

Hi,

I am currently looking for the B9003 unit... can someone suggest the best place to pick one up? I heard ebay is a good source, however I cannot find one listed at the moment.

How long does it take to swapout the unit? I've changed headunits before, but this sounds more involved as I'll need to consider the antenna placement.

Anyway, I hope you manage to complete the installation without problem!

Many thanks! Stuart

Link to comment
Share on other sites

Just fitted the b9003 full screen sat-nav to my LC4 Land Cruiser; it originally came with the TNS300 with ETA system but I decided to swap it out for the AISIN B9003 full screen version.

So far so good but I've got a few issues...

1. Managed to find out which wire the "reverse" signal was on so with my Pioneer rear view camera when put into reverse the screen changes to the rear view camera...GOOD...Wait...no image, I assume this is because there is no power going to the camera (I've used all the connections on the 4 pin connector ont the back of the B9003 i.e. 2 for the camera and two for +ve power and ground. When in reverse the screen displays the usual "Check Your Surroundings" message but no image. So it is registering when in reverse, but it's not displaying any image from the camera. Might try taking power from the reverse lights...pain!

2. Can identify the parking (hand) brake signal too

3. CAN'T identify the speed signal, the TNS300 doesn't seem to come with one, it only seemed to come with 2 inputs (reverse & hand-brake) both of these inputs have been confirmed via the diagnostic mode on the B9003...does anyone know where I can get the speed signal from, I can't believe that the TNS300 doesn't use the speed signal but I can't for the life of me find it!

My Land Cruiser is in bits and needs the forums help!

1. I've fitted one to my RAV, first up yes sound like you've connected up the reverse sensor OK, all this does is to supply a +12v signal to the head unit to notify that the car is in reverse usually taken from the reversing light circuit, you have 2 choices with the camera no one is sure about the output voltage coming from the head unit but its not +12volts and most aftermarket camera's require 12v, so you can either permanently power the camera ( wish I had done that) or take the supply from the reversing lights so you have to wait a second or two for the camera to powerup.

2. The handbrake sensor (someone may correct me if I'm wrong) is for stopping the Sat Nav destination from being entered whilst moving,this is a requirement for the US market so I would bother connecting it.

3. I didn't need to connect the speed signal in the RAV if it has the standard 10way & 6 way block connectors you might find its part of the loom, when you first install the NAV you might find it takes sometimes upto 1/2 hr before the system finds itself ( make sure the antenna is not too restricted though)

If you need any connector diagrams or diag manuals just PM me.

:thumbsup:

Hi,

I am currently looking for the B9003 unit... can someone suggest the best place to pick one up? I heard ebay is a good source, however I cannot find one listed at the moment.

How long does it take to swapout the unit? I've changed headunits before, but this sounds more involved as I'll need to consider the antenna placement.

Anyway, I hope you manage to complete the installation without problem!

Many thanks! Stuart

It's actually simple my granny could do it, remove the 4 hex screws around the radio/vents then remove 4 bolts from around the radio, strap antenna to pipe behind radio/head unit plug in 10 way & 6 way connectors from the toyota loom plug in car ariel & antenna, swap radio brakets to head unit replace all the bolts and hey presto, took me 10 mins max the first time I fitted one.

The head units turn up from time to time there was one on ebay recently alternatively I've seen one or two here on TOC for sale very recently.

Any other issues regarding speed & reverse sensors on TOC are irrelevant you only need the 10 & 6 way blocks from current radio.

;)

Link to comment
Share on other sites

Just fitted the b9003 full screen sat-nav to my LC4 Land Cruiser; it originally came with the TNS300 with ETA system but I decided to swap it out for the AISIN B9003 full screen version.

So far so good but I've got a few issues...

1. Managed to find out which wire the "reverse" signal was on so with my Pioneer rear view camera when put into reverse the screen changes to the rear view camera...GOOD...Wait...no image, I assume this is because there is no power going to the camera (I've used all the connections on the 4 pin connector ont the back of the B9003 i.e. 2 for the camera and two for +ve power and ground. When in reverse the screen displays the usual "Check Your Surroundings" message but no image. So it is registering when in reverse, but it's not displaying any image from the camera. Might try taking power from the reverse lights...pain!

2. Can identify the parking (hand) brake signal too

3. CAN'T identify the speed signal, the TNS300 doesn't seem to come with one, it only seemed to come with 2 inputs (reverse & hand-brake) both of these inputs have been confirmed via the diagnostic mode on the B9003...does anyone know where I can get the speed signal from, I can't believe that the TNS300 doesn't use the speed signal but I can't for the life of me find it!

My Land Cruiser is in bits and needs the forums help!

1. I've fitted one to my RAV, first up yes sound like you've connected up the reverse sensor OK, all this does is to supply a +12v signal to the head unit to notify that the car is in reverse usually taken from the reversing light circuit, you have 2 choices with the camera no one is sure about the output voltage coming from the head unit but its not +12volts and most aftermarket camera's require 12v, so you can either permanently power the camera ( wish I had done that) or take the supply from the reversing lights so you have to wait a second or two for the camera to powerup.

2. The handbrake sensor (someone may correct me if I'm wrong) is for stopping the Sat Nav destination from being entered whilst moving,this is a requirement for the US market so I would bother connecting it.

3. I didn't need to connect the speed signal in the RAV if it has the standard 10way & 6 way block connectors you might find its part of the loom, when you first install the NAV you might find it takes sometimes upto 1/2 hr before the system finds itself ( make sure the antenna is not too restricted though)

If you need any connector diagrams or diag manuals just PM me.

:thumbsup:

Hi,

I am currently looking for the B9003 unit... can someone suggest the best place to pick one up? I heard ebay is a good source, however I cannot find one listed at the moment.

How long does it take to swapout the unit? I've changed headunits before, but this sounds more involved as I'll need to consider the antenna placement.

Anyway, I hope you manage to complete the installation without problem!

Many thanks! Stuart

It's actually simple my granny could do it, remove the 4 hex screws around the radio/vents then remove 4 bolts from around the radio, strap antenna to pipe behind radio/head unit plug in 10 way & 6 way connectors from the toyota loom plug in car ariel & antenna, swap radio brakets to head unit replace all the bolts and hey presto, took me 10 mins max the first time I fitted one.

The head units turn up from time to time there was one on ebay recently alternatively I've seen one or two here on TOC for sale very recently.

Any other issues regarding speed & reverse sensors on TOC are irrelevant you only need the 10 & 6 way blocks from current radio.

;)

Hi Rowena461,

Forgot to mention, its for swapping out a Landcruiser LC4 TNS300 unit, so I'm guessing it will be slightly different removal from that of a Rav4. As its swapping out a satnav unit for another satnav unit it sounds like its a very simple operation.

I'm glad this is so straight forwards, as originally I would have gone for a Landcruiser LC5 because of the full map satnav, but would have paid alot more for the car.

Thanks for the info, very helpful!

Stuart

PS: Please email me at sk@supportguys.co.uk if you have a new B9003 satnav unit for sale!!

Link to comment
Share on other sites


  • 1 month later...

Belated Update....

All fitted now, I got the Handbrake and speed signal wires mixed up, what I thought was the handbrake signal was actually the speed signal; I found this out by connecting it up to the speed signal input and then going into the diagnostic mode and driving around a bit and noticed the Kph/Mph registering the pulses.

Also I piggy backed off the 12V signal from the reverse wire to power the rear camera, this way the camera is not permanently on so less wear on the components.

Anyway it'a all fitted now a looks completely OEM especially the rear view camera which always gets remarks when passengers notice it kicking in. Might try and post some pictures.

Anyone retro fitted the air leveling suspension form the LC5? Could be the next project (I hear you saying why on earth didn't you just buy an LC5) ;o)

Link to comment
Share on other sites

  • 2 years later...

Hi there,

I also have LC4 2004 and would like to get rid of the TNS300 (TNS a pain so just use my TOMTOM...) and put in the LC5 system. Do you just need the touch screen head unit? Or, do you need to replace the DVD player under the drivers seat as well?

Whats the going price for the gear second hand?

Paul

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership