Jump to content
Do Not Sell My Personal Information


Mr2 Mk2 G-limited T-top 1990


classicol
 Share

Recommended Posts

Hi there. Hope somebody might offer me some help. I have 1990 Mk2 T-Top which is mechanically very good. However when I accelerate very hard(foot to the metal), it lags and misses. If I accelerate slowly it is much better but when it reaches higher revs off it goes missing again. Anyone with any suggestions. I thought maybe a sensor or plugs?? Just bought it and would love to sort it out without main dealer prices. Even as it is Its so much fun. Looking forward to any suggestions. Maybe someone has had same problem.

Cheers

John :wacko:

Link to comment
Share on other sites


Hi there. Hope somebody might offer me some help. I have 1990 Mk2 T-Top which is mechanically very good. However when I accelerate very hard(foot to the metal), it lags and misses. If I accelerate slowly it is much better but when it reaches higher revs off it goes missing again. Anyone with any suggestions. I thought maybe a sensor or plugs?? Just bought it and would love to sort it out without main dealer prices. Even as it is Its so much fun. Looking forward to any suggestions. Maybe someone has had same problem.

Cheers

John :wacko:

mine was similar mate when accelarating 'hard foot'.....did a service on it and was much better. Make sure you 'hard foot' it when its cold tho...

and welcome hope you enjoy it mate!

Link to comment
Share on other sites

Hi there. Hope somebody might offer me some help. I have 1990 Mk2 T-Top which is mechanically very good. However when I accelerate very hard(foot to the metal), it lags and misses. If I accelerate slowly it is much better but when it reaches higher revs off it goes missing again. Anyone with any suggestions. I thought maybe a sensor or plugs?? Just bought it and would love to sort it out without main dealer prices. Even as it is Its so much fun. Looking forward to any suggestions. Maybe someone has had same problem.

Cheers

John :wacko:

mine was similar mate when accelarating 'hard foot'.....did a service on it and was much better. Make sure you 'hard foot' it when its cold tho...

and welcome hope you enjoy it mate!

Thanks. Guess that might sort it. New leads and plugs won't go amiss. Wondered if it could be a fuel starvation or mixture problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership