Jump to content
Do Not Sell My Personal Information


Supra 3l Turbo Splutters When Cruising.


Gr1mreaper
 Share

Recommended Posts

Hello all, I hope someone can help me. I have a 1991 Supra mk3 Turbo. It was running fine but for being a little lumpy on idle, cruised well and take off was great. I was coming out of a car park yesterday and accelerated hard in 1st gear, now the engine seems to splutter when cruising at all speeds up to seventy where it seems it doesnt do it. Any one have any ideas ? it still smooth if your accelerating and the turbo still sounds well its just when the throttle is level or when you decrease speed through the gears you can feel it being lumpy.

Any help greatly appreciated.

Leighton

Link to comment
Share on other sites


Have any modifications have been done to the car????

Is your servicing up to date?

If the answer to the above is yes I am taking the plugs and lead to be in good shape, so is there ant water/oil sitting in the chambers between the cams where the plug tops are??

Link to comment
Share on other sites

Head gasket has been done reasonably recently, so I thought i'd pop a plug out............... sure enough found it gently simmering in a pool of old Oil, as most of the plugs are out of the 6!!!! I assume plugs and leads are the culprit and it was just a coincidence it appeared to be something other after a fast take off, although it was no way near flat out redlining (was about 4 - 5k rpm). Ive also found numerous rubber pipes split so im amazed it ran at all!!! Thanks for your post though and if anyone knows where I can get a new turbo hose/pipe (From airbox to turbo, the big fat one, has other smaller pipes attached) nr Manchester U.K your help would be appreciated 2nd hand will do fine. I will post back after I fit the new plugs/leads and pipes, not forgetting rocker gaskets, to confirm all ok. From what ive read I get the impression Supras tend to eat plugs and leads alot ?. My Subaru didnt hehehe!!

Many thanks

Leighton

Link to comment
Share on other sites

Ewww Subaru :P

Yup change the cam cover gaskets, make sure the seals are all clean and the covers are not put back too tight!!

Scrappies etc should have a second hand accordian hose, but they tend to perish after 12 or so years so many good ones in scrap cars have already been taken! I did have a spare but its sold now...

While the cam covers are off I'd be tempted to check the torque settings on the headgasket, I do mine at 72 lb/ft work from the inside ones out.

-the most commom heaggasket cause is not torquing the head enough, or not doing it in several passes.. I always recheck them 1000 or so miles after it was put on.

Link to comment
Share on other sites

Alas the problem has reared its head!!! It IS the head gasket once again. The guy whom I bought the car off had the gasket done not too long ago so im going to pop it back into the garage that did it and hopefully they can do the job properly this time!!!. Just incase they spit there dummy out how much roughly do garages charge to do the head gasket ?. Just a note on your theory above that the head bolts may not be tight enough, I could torque them down myself to be sure before taking to garage ? what do you think?. It is now causing pressure to the cooling system and I heard the cooling fan cut in for the 1st time today. I think when I floored it, it has breached the gasket and is going to need one regardless.

Many thanks for your help though.

Leighton

Link to comment
Share on other sites


if there isa receipt take it back and demand they do it properly.

if not, DIY, -its the only way you can be sure that its done properly!!!

What are the symptoms you are getting? other thena presurased coolant system?

Link to comment
Share on other sites

no white smoke? no mayonaise in the Oil cap??

To me that sounds like a dodgey rad cap!!!

I'd replace the rac cap and thermostat, fluch out the coolant and refil.

You get these muppet garages that replace the headgasket without cheking over and looking after the rest of the coolant system.. result? it blows again.

Id be tempted to do all that, remoe and check all the plugs, check the compression.

if water/oil has got in the plug wells again, see whee its coming from (cam cover seals, rear heater matrix hose, etc etc)

So many "phantom heagaskets" are misdiagnosed rad cap and 'stat problems!!!

Link to comment
Share on other sites

Id be tempted to do all that, remoe and check all the plugs, check the compression.

Also worth taking the rad off and flushing it through (both ways) with the garden hose.

I would also make sure they compression test the head and re skim, my MKiv was doing a similar thing and the head was twisted ....all sorted now and goes like a dream....

Link to comment
Share on other sites


I personally don;t reccomend skimming the heads unles they really are way way out!!!! decent retorquing/allowing to settle will sort it out usually... you often fine with skimmed heads they are true untill you bolt the thing back together!!!

if it is warped.. find another one that is straight :thumbsup: they go for penuts second hand...

Link to comment
Share on other sites

Oh Pooh

My supy is spluttering on take off and I've fitted new plugs. It is always stalling in traffic also, sometimes it is a git to start again (10 minutes of clicking). I have also noticed that the Oil pressure drops to about 20 lbs/in2 at low revs. The o/d off light is flashing so it could be a faulty speed sensor. Where ever that is! Also still no speedo and the fuel consumption is 80 miles to half a tank. What the hell is happening to the thing!

Hope it isn't the dreaded Blown HG

Regards

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership