Jump to content
Do Not Sell My Personal Information


Central Locking Problem- 98 Avensis


chorn
 Share

Recommended Posts

This is driving both me and the garage crazy.

Central locking goes on the blink, and the only way to open/close doors is using the key manually. Closing is fine- one turn and it locks. But opening, the cylinder can turn anywhere from 1 to 10 times before the lock clicks open.

This has been back to the garage 5 times in the last year- the garage fix it for free and when it comes out both keys work on the day. Usually then one key goes after anywhere from a day to a month (i.e. it doesn't work) though the second key does work for a while afterwards- then it too goes on the blink and I'm back to manually locking/unlocking.

It's bizarre how one key stops working while the other is fine for a while. I wouldn't mind if I could just manually open the lock with one turn of the key- but having to turn the key 10 times is just a real pain.

Any thoughts/help appreciated.

Chris

Link to comment
Share on other sites


Hi.

Don't mean to take over this question, but I have similar problems...

I have an Avensis 2.0 -99, the remote locking works sporadically. Usually I can open all locks with either the remote key or use the key in the lock, but locking the doors are sometimes impossible.

It can be a month and everything works fine, then suddenly, the locking function stops working so you have to work around on the locks on all doors from the insíde of the car, then lock the drivers door from the outside.

It has happened that you turn the key in the wrong direction, ie unlocking all doors again so you have to start the procedure again. Very annoying. :angry:

Also, at one time my kids press the emergency-light button (is it called that, the four-way blink), anyway, then the locks opened and closed in tune with the blinking. After that, the locked worked fine for 2 months, no problems at all, then it started again.

Also, it could lock and unlock itself automatically when driving

To me it sounds as I have some problems with an earthing cable or something like that. The problem is that I have no idea where to start.

Someone to help?

Link to comment
Share on other sites

This is driving both me and the garage crazy.

Central locking goes on the blink, and the only way to open/close doors is using the key manually. Closing is fine- one turn and it locks. But opening, the cylinder can turn anywhere from 1 to 10 times before the lock clicks open.

This has been back to the garage 5 times in the last year- the garage fix it for free and when it comes out both keys work on the day. Usually then one key goes after anywhere from a day to a month (i.e. it doesn't work) though the second key does work for a while afterwards- then it too goes on the blink and I'm back to manually locking/unlocking.

It's bizarre how one key stops working while the other is fine for a while. I wouldn't mind if I could just manually open the lock with one turn of the key- but having to turn the key 10 times is just a real pain.

Any thoughts/help appreciated.

Chris

Same happened on my old Avensis Turned out to be the central locking ECU.It would work after reprogramming for afew days then stop working again with both keys.

Sorry for bad news. :(

Cheers,

Nick.........

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership