Jump to content
Do Not Sell My Personal Information


Starters Gone.............


Neil Clark
 Share

Recommended Posts

Had a alarm fitted and it fixed my central lockin problem!!, then later on in the day the starters gone :!Removed!: . Its in the garage to have it fixed tomorrow, any idea how much?

The relay is clickin but the starters doin nothin, does this sound right?

Neil

Link to comment
Share on other sites



It's more likely the Battery terminals are loose, and haven't been connected up to the car properally (the Battery was probably disconnected to install the alarm). This happens to me all the time (when I move batteries in and out of different vehicles) so take the leads off the terminals, clean them up, clean the Battery terminals, and make sure the leads are securly connected to the Battery. Twist them around a bit too. I'm willing to bet this is your problem and is free to fix :).

P.S A blown EFI fuse won't stop the engine from turning over, it will stop it firing up.

Link to comment
Share on other sites

Ok, believe it or not, the MR2 needs lots of amps to start. If there is so much as a slightly bad connection it will click like this (I know cos it's happened to me a few times). The strangest thing is, all the lights will seem like they're running under normal power, the dash lights will come on, but the damn engine just will not start and will keep clicking (this normally sets my alarm off which then needs disarming etc etc..). Bearing in mind the large number of amps required, the Battery might be a bit flat (for one reason or another), do you have a charger? I would suggest you try fully charging it, and see if that makes a difference. Connecting a Battery to an MR2 can be a right pain in the bum - but try these things, honestly, it might just work :).

Link to comment
Share on other sites

Oh and if you still don't have any luck, your solenoid may be stuck. I'll post a piccy to show you where it is later - off drinking now ;)

Link to comment
Share on other sites


He didnt disconnect battery mate, all dash lights comin on anyway and it started 6-8 times after alarm went in. Its just clickin from the engine compartment but not turnin, any more ideas to try tmrw?

Neil

Just bought a 91 GT and after a day I had the very same thing, turned out to be a f :censor: d alternator, got it replaced and running like a charm now.

Link to comment
Share on other sites

I'm still convinced the Battery is low, like I said before - lots of amps needed to start an MR2 - Trust me I've been there before - several times. Been trying to find that picture, bit tired/drunk at the moment I'm afraid - the soonest I can dig it out will be Monday. I don't think it's a starter issue anyway, I've owned an MR2 for over five years, and have a lot of experience in all of the common problems - including this one. Try charging the barrery - I'm sure thats the problem. If so the alternator may need work, though the alarm could be wired incorrectly and causing too much power drain.

Link to comment
Share on other sites

Right nitemate over,

The garage replaced starter with a new one (cost unknown as yet!!) and it was the same!!

They ended up tracin back the problem to the toyota immobiliser which is workin aswell as the cat1

How do i remove or disconnect the immobiliser? at the min you have to lock and unlock the door before it starts!

Thanks guys :thumbsup:

Neil

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership