Sign in to follow this  
viperroom_112

Help

Recommended Posts

i need some help guys . I have a sony cd player and a sony 4 channel amp ... everything had been running fine until i recently ... every time i turn the soundsystem down or change track there is a popping sound , now the amp is earthed to a seat bolt which should be ok ??? i have checked it and it is pretty secure ... also i have my tweeters with built in crossovers running from my headunit , whereas my door Speakers and sub are running from my amp .. unfortuntely when my cd player is off and the car is running i get a loud buzzing out of the right hand tweeter .... but when i switch the cd player on i cant really here it ... any ideas on what could be causing these problem s ... may thanks

dm

Share this post


Link to post
Share on other sites

Bad earth for the popping. 100% positive! Clean up your connection a bit and see if it helps.

The tweeter's a bit of an odd one, not sure on that. If it started at about the same time as all your other troubles, chances are its related!

Share this post


Link to post
Share on other sites

thanks very much , will get out and try the earth again .... could be the amp connection if you no wat i mean ?! .... as for the tweeter i am tottally unsure ... it sounds like there is a power cable ear it causing static ??

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this