Jump to content
Do Not Sell My Personal Information


Please Help! - Fuel Pump Problem


ae86175000
 Share

Recommended Posts

Hi all! Great site!

I have an 86 corolla gt-s hatch that will not start. It gets a spark, but no fuel. The fuel pump does not run when ignition is turned to "ON" or "START" positions. I removed the pump from the tank and was able to run the pump with it connected straight to the Battery. I reconnected the pump to its connectors and it still would not run.

Some background info:

The car was running great when I drove the car to my g/f's house and parked it. We went away for Thanksgiving weekend (we took her truck, not my car), and when we got back, my gt-s would not start! I replaced the distributor cap and rotor button after not having gotten spark on ANY of the plugs, but I still could not get a spark. Then, my g/f noticed arcing across the ignition coil posts (she saw this while I was cranking the engine over). I replaced the ignition coil, and that fixed the 'no spark' issue, but the car *still* would not start! I removed some plugs and none of them smelled like they had any gas on them. I had my brother listen for the normal 'click' that the fuel pump makes when it turns on, but he did not hear anything and neither did I. He jarred the bottom of the fuel tank to see if maybe it was stuck (common problem with fuel pumps), but still no click. We detached the hose from the fuel filter and I cranked the engine -- no fuel spurted out of the line! We drained the fuel (I had a full tank :( ), detached the tank, and removed the fuel pump. We immersed the pump in some fuel in a container and connected the pump straight to the Battery using 2 wires, and it ran perfectly! We reconnected the pump and tried again; it still would not power on. We went to an auto parts store, where the most knowledgable person there recommended checking the pump relay. My brother obtained 2 different relays of the exact same type (OPEN CIRCUIT RELAY, model no. 85910-30050, found behind the glovebox) and we tried 'em out. The pump STILL would not run! That was the last thing we tried, and I knew I couldn't just hook the pump up to the Battery with a switch, b/c the pump's power is controlled by the computer and is way to complicated. Also, I checked all the fuses, and replaced one that was burnt out (most likely happened b/c of the defective ign. coil) but the pump still would not run. I suspect some damage may have occurred to other related circuits (although every other electrical component in the car works fine) when the ign. coil was arcing, but I can't be sure, and I don't know how to test circuits using a voltmeter.

ANY and ALL advice you guys could offer would be GREATLY appreciated!

Also, please e-mail me your replies to: philip.schember@fmr.com, I can check it more often than this message board (If you are e-mailing me, please do not include any questionable lang, since it is my work e-mail. I won't be able to receive any messages with bad lang in them).

Thx! :)

-ae86175000

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership