Sign in to follow this  
ajcluck

Crail

Recommended Posts

hey all, just like to thank all who gave me the advice on the mods to my car, i took it to crail yesterday and managed a 13.4. although a starlet gt turbo managed a 13! :angry:

Share this post


Link to post
Share on other sites
hey all, just like to thank all who gave me the advice on the mods to my car, i took it to crail yesterday and managed a 13.4. although a starlet gt turbo managed a 13! :angry:

what all mods had u done? did u reset the ecu before your run?

Share this post


Link to post
Share on other sites

no i didnt reset the ecu, was i supost to? got the boost upped on sat!

Share this post


Link to post
Share on other sites
no i didnt reset the ecu, was i supost to? got the boost upped on sat!

lol just a wee trick some gt four owners use on drag strips. if you take out the ecu fuse for about 10 mins it resets the ecu, once you reset the ecu the gt four needs to "relearn" its fueling so to begin with it over fuels and in theory gives you a little more power for a while until the ecu has "learnt". something to bear in mind for your next run. what did u up the boost too and what controller did u end up with. have u got an induction kit de cat pipe? aftermarket mid and rear section exhaust? or is the boost controller the only mod?

was the glanza modified?

i would always check for errors codes before a drag too. do u know how to do this ok? there are a few error code that make the gt four run in "safe mode" and can effect performance

Share this post


Link to post
Share on other sites

ye i have an aftermarket exhaust system, hks induction kit, i went for a blitz controller, set me back bout £250, it was set at 1.1bar but i think i mite have a little boost creep! ahh no i never knew that, no i also dont know how to look for error codes either. oh hell ye, it was a flying machine, couldnt get close enough to the car to see wot mods he had done tho!

Share this post


Link to post
Share on other sites

ok to check for error codes locate this diagnostics port (top righthand corner of engine bay) u can unclip this to make it easier to work with. under the lid it will name the connections, bridge two of the connectors together marked “E1” and “TE1" you can use a paper clip or bit of wire. leave this in and go and turn the car on (dont start the engine) have a look at the engine management light (the orange 1 on the right hand side) if it flashes constantly then u have no error codes but if it flashes slowly then u have error code. the error code is identified by the amount of flashes ie flash..flash..flash..flash..flash...................flash..flash..flash..flash is code 54 (charge cooler level).

if u need me to tell u where the ecu fuse is then just let me know

Share this post


Link to post
Share on other sites

Do u have a de cat pipe/downpipe on it too? i take its 3 inch if u think u are gettin boost creep?

Share this post


Link to post
Share on other sites

no i still have the cat, looking for a cheep down pipe at the mo! it was on the was to crail the boost was up to 1.2bar, the fuel was cutting out, so i swithched the engine off then it never did it again!

Share this post


Link to post
Share on other sites
no i still have the cat, looking for a cheep down pipe at the mo! it was on the was to crail the boost was up to 1.2bar, the fuel was cutting out, so i swithched the engine off then it never did it again!

well check for errors codes mate and let me know how it goes. you shouldnt b gettin boost creep if you still have the cat i dont think. what size is the exhaust from cat back?

wouldnt b usin any more than 1.1 bar on a standard engine. if you want to up the boost then get a forged engine. dont be tempted to remove the fuel cut, its there for a reason. think most people get fuel cut on anything about 1.2 bar

Share this post


Link to post
Share on other sites

cool, i will go home 2nite and look at the error codes. it aint done it since, it was runnin smooth as u like after i switched it off then on again. u got any suggestions bout a gd cheap downpipe? not to sure on the measurements of my exhaust all i no is its a blitz nur spec, i do have an aussie mid section tho

Share this post


Link to post
Share on other sites

decent time :)

The Glanza must have been running either a blitz k24/k26 turbo or TD04 to get those times.

Re the ecu, you really dont want it running any richer than it does stock! they overfuel like mad :lol:

Share this post


Link to post
Share on other sites

that was will a 3/4 tank and my old man in the car, and he is a big loon! ye it must have been something big cause the turbo made some noise when spooling up, but someone has told me that it may even of had NOS!

Share this post


Link to post
Share on other sites

lol, good times mate, when it comes to Starlets/Glanza's you should never under estimate them, my mate mapped one with a TD04 kit and it would light up coming on boost in 4th!!!

Share this post


Link to post
Share on other sites

ye they are awsome, i had one before i got my gt-four, i couldnt aford to keep replacing the front tyres! :lol: hopefully my four will kick some serious ***** once its finished!

Share this post


Link to post
Share on other sites
ye they are awsome, i had one before i got my gt-four, i couldnt aford to keep replacing the front tyres! :lol: hopefully my four will kick some serious ***** once its finished!

u check for error codes?

Share this post


Link to post
Share on other sites

sorry buddy, been that swamped at work had to take stuff home with me, will def. do it 2nite tho!

Share this post


Link to post
Share on other sites

a 13.4 is a very good time, 13 dead on a glanza must have been seriously modified, a lad i know who used to have a starlet running 200bhp managed 14.9....

Share this post


Link to post
Share on other sites
a 13.4 is a very good time, 13 dead on a glanza must have been seriously modified, a lad i know who used to have a starlet running 200bhp managed 14.9....

hum i had a standerd starlet turbo with nakers shocks on the frunt and i still did a 15 1/4 mile

Share this post


Link to post
Share on other sites

one thing you need to know about crail, the tarmac is crud!!! my mate knocked over half a second off his 60foot times by taking his car down south to run at rotor stock.

Share this post


Link to post
Share on other sites

I've done Crail twice now - the latest was with the RAV4 turbo, and using 225/45 x 18 lightweight DARE wheels and Continental well worn tyres. Got a launch time of 2 seconds and overall around 13.4 as well. The terminal speed is about 90 - which I'm disappointed with. The engine seems to be pulling ok but not getting up to high rpm in 3rd or 4th gear. Bit of work to do on it! We changed the exhaust back box to straight thru after the 1st visit. No cat fitted.

On the 2nd run, I kept the weight down - apart from my size and weight which is the biggest problem!!!

Using the diff lock on the 2nd visit made a difference to the launch time as well as the front wheels coming off the ground didn't affect the accelaration so much.

Sourced a sway bar for the rear from USA, but still to be fitted as it will mean altering exhaust. There is a bit of movement on the rear under launch which makes life exciting! :lol:

Must say that a few guys got a surprise seeing a RAV4 hairing down the straight in front of them!

Share this post


Link to post
Share on other sites

it must have been some sight mate! i think the aerodinamics is going to be your biggest enemy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this