Sign in to follow this  
Mr2_NA

Alternator and charging question...

Recommended Posts

Newbie again 😉

Bought my mk2, popped in a new batt to get me home as the alternator had had it and had no belt either. Drove fine, just the usual warning lights telling me batt ain't charging, bla bla bla...

After 90mins grafting pulled the old alternator out

Put the new one in, put the belt on, tightened the belt up to the tension my ORIGINAL manual says.

Re-connected my new batt which had lost its charge from driving it home, good 90mins drive.

Started her up, nothing. Dash light for my handbrake was on and clock was dimm.

Took batt out and put it on an oldish halfrauds charger which is rated at 12v 5amps I think.

How long should I charge it for?

I did do it for 4-5 hours yesterday, but had no green light on the batt, put it in car started, no warning lights. Drove 10mins down the road, clock dimmed so I turned back and parked her up.

Tried to start up this morning and it sounded like the batt didnt have enough juice to start up. So its back on charge again!

If it doesnt work, gona try n get a multimeter in a few mins, will it be that voltage pack on the alternator even though there are no warning lights?

Il report back when I get a multimeter, main question is how long for the Battery on charge at 5amps or milli amps, whatever it is 😉

Thankyou B)

Share this post


Link to post
Share on other sites
 

Doesn't your dash have a voltmeter?

As to the charging rate, it'll be 5A as 5 mA would take forever.

What rating is your Battery? A 50Ah Battery would take 10 hours* to charge at 5A because storage capacity in Ah is the Amps * Hours.

*Actually it'll take a bit longer than that due to charging inefficiency and it'll also depend on whether the charger really is up to the job of delivering 5A continuously. But Ah / A gives an indication of how long it takes to fully charge from flat.

Share this post


Link to post
Share on other sites

OK, my Battery is fully charged and fairly new. I tend to leave it on the conditioning charger a lot as I don't use the car that much.

So this should be normal operation with no problems:-

1. Turn ignition key until dashboard lights up. Voltage needle sits half way up the white zone.

2. Turn key to start engine. Voltage needle drops very slighty due to starter motor putting load on Battery.

3. Engine running. Voltage needle sits slightly higher up the white zone. The Alternator has to supply a slightly higher voltage than the Battery to charge it.

If Battery wasn't fully charged then I'd expect:-

1. the needle to be sat lower on the scale. Much lower if Battery is very flat.

2. needle to drop very low on starting. Car may or may not start.

3. can't remember this one. Either needle could rise quite high as alternator works very hard to charge it up, on the other hand the Battery would be soaking up all the power so that could cause the needle to remain low (but probably in the white zone) until the Battery has been charged.

Share this post


Link to post
Share on other sites

From what you say, I need to do a days charge on my Battery ^_^

Well, its been on for a couple of hours, so il give it till 5-6ish this evening or when that gren LED comes on :)

The needle does go high, presuming the alt is charging, but then needle drops slowly, when about 1/4 up the fuel starts to splutter. So the alt is not able to produce enough voltage with the batt being so drained its just dying.

I will report back this evening :)

Thanks T600 ^_^

Share this post


Link to post
Share on other sites

I understand what you're saying there, but there are a few questions to resolve I think.

1. You don't need a fully charged Battery to start the car; the Battery is easily big enough to cope with the car being stopped and re-started many times. So a few hours charge at that rate should be enough to start the car at least one or twice.

2. Once the car is started, then if everything is working properly the alternator should take over the job of charging the Battery - and it probably does it at a much faster rate than 5A. So unless you're running a lot of load e.g. lights on, or lots of ICE etc, then there shouldn't be a problem once the car starts. The charging circuit should automatically take care of supplying more or less power to the system according to how low the Battery's charge is. So just after you start the car the alternator provides all the current the car needs plus lots more to top up the Battery, then as the Battery fills up the alternator cuts back to supply only what the car is consuming.

The needle going high is a good sign and suggests that the alternator is producing power, but why isn't that resulting in the Battery charging up? I can't think of a good explanation for that other than possibly a dodgy Battery, but that is eliminated by the fact that you've replaced the Battery, and confirmed by the fact that on the mains charger the Battery does charge up.

If you managed to get that volt meter then take some readings of the voltages when the engine isn't running, then again with the engine on. And see how the voltage varies according to the idle speed.

Also check all of your connections. And listen for any sign of the alternator belt slipping when the engine is reved up.

Share this post


Link to post
Share on other sites

Slap a multimeter on there to make sure the altenator is actually charging!

Share this post


Link to post
Share on other sites

Its not charging the Battery! Bloke down the round says if I have just replaced the nator I should look at the regulator.

Whats that and where is it located and what does it do?

Share this post


Link to post
Share on other sites

It converts the Alternator's AC output into DC and regulates the voltage and current so that the right amount is produced to keep the Battery charged whilst running all the other electrical equipment at the same time.

I thought the regulator was built into the Alternator on the SW20? And that regulator problems usually resulted in over-charging rather than under charge.

Share this post


Link to post
Share on other sites

Yes the regulator is inside the alternator. Overcharging is normally the problem as already stated. Before you start ripping the replacement out check this:

http://www.mr2-tech.com/bgb/mechanical/vol...ging_system.htm

Page CH-4 etc.

Share this post


Link to post
Share on other sites

Sorted :) ^_^

I jump started the alternator :|

Don't know if anyones ever heard of that being done before!

I just used my old batt, - on the chassis and let the engine run, just tapped the + on the 8mm bolt head on the alternator and viola :)

Happy days, just been for a spin, batt is now green, voltage reads over half way as it still needs charging up.

Share this post


Link to post
Share on other sites

Nope, never heard of that.

How does it work then? I hope it doesn't just fry the regulator which is what can happen if you short the output when the engine's running.

Share this post


Link to post
Share on other sites

The term for it is called "Exciting the alternator" I speak the truth!

I used a spare Battery, started the engine, connected the neg of the spare to the chassis then just tapped the lead of the possitive on the 8mm bolt that sticks out of it.

Like you said, it could fry something, but the risk paid off.

Got a knock from the suspension now so be looking for me in other sections!

Thanks again everyone for your help :)

Share this post


Link to post
Share on other sites

So positive terminal from Battery to tap the positive 8mm bolt on alternator?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this