Jump to content
Do Not Sell My Personal Information


Flashing Overdrive Light?


n1ck
 Share

Recommended Posts

Hi all. I'm after some knowledge!

I come out from a night shift this morning and as I useally do hop into my car and take a steady 10mile drive home, but this morning after approx half a mile driving my overdrive light started to flash every second(ish) and also I have no Speedo which I'm assuming are both linked because all was fine on the way to work. I pulled over and turned the engine off and re-started it and again after about 30 seconds it starts flashing again. I've done a search here and have read speedo problems seem to be linked to a sensor in the gearbox, but find none which mentions a flashing overdrive light.

I have a 92k G-Limited 2.0i T-Bar import Auto which has done 77,000 miles.

Typical when the advertised car is for sale too!

Anyway any help appreciated.

Thanks.

Nick.

Link to comment
Share on other sites


Hi all. I'm after some knowledge!

I come out from a night shift this morning and as I useally do hop into my car and take a steady 10mile drive home, but this morning after approx half a mile driving my overdrive light started to flash every second(ish) and also I have no Speedo which I'm assuming are both linked because all was fine on the way to work. I pulled over and turned the engine off and re-started it and again after about 30 seconds it starts flashing again. I've done a search here and have read speedo problems seem to be linked to a sensor in the gearbox, but find none which mentions a flashing overdrive light.

I have a 92k G-Limited 2.0i T-Bar import Auto which has done 77,000 miles.

Typical when the advertised car is for sale too!

Anyway any help appreciated.

Thanks.

Nick.

Do you have any pictures mate ? ive never seen overdrive before

Link to comment
Share on other sites

Thanks for the replies. :D

I have posted a picture of the light as requested.

Someone at work seems to think I need to check my gearbox oil level as its an automatic and the overdrive light could be a warning light for low oil level and this also could electronically be in connection with my speedometer not working.??

I'm not to sure on this theory but its probably an easy check so worth a try.

Just for reference the overdrive function works fine when enabled.

Once again thanks for the replies.

Nick.

post-41331-1217242095_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership