Jump to content
Do Not Sell My Personal Information


  • Join Toyota Owners Club

    Join Europe's Largest Toyota Community! It's FREE!

     

     

Coolant Not Flowing D-4d


lee_123
 Share

Recommended Posts

I have recently purchased a 2002 Yaris 1.4 D-4D. The heaters have not been working so I put it into my local garage. The mechanic found that the water was not flowing round the engine.

He has tried a new pump and thermostat but this has not solved the problem. The car is running well and there is no signs of the head gasket going:

The car does not lose water,

There is no loss of power.

The oil looks okay.

There does not appear to be exhaust fumes leaking into the water.

Can someone please suggest any possible reasons for this problem.

Thanks!

Link to comment
Share on other sites


Latest Deals

Toyota Official Store for genuine Toyota parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share







×
×
  • Create New...




Forums


News


Membership