Sign in to follow this  
chillibabe

Check Engine Light

Recommended Posts

Help I have a Ln130 surf k reg the engine check light has came on done check it says engine coolant temp sensor would this make the engine go in limp mode and ther are two sensors one is the sensor for the fan what is the other

:unsure: any advice please

Share this post


Link to post
Share on other sites

On the thermostat housing you have two sensors one is fan the other is temp gauge, also you should have a temp sensor just above the starter motor, which is probably the one at fault.

Not 100% sure that you have one but the 3ltr engines do, and this controls the gear change and glowplugs.

Share this post


Link to post
Share on other sites
On the thermostat housing you have two sensors one is fan the other is temp gauge, also you should have a temp sensor just above the starter motor, which is probably the one at fault.

Not 100% sure that you have one but the 3ltr engines do, and this controls the gear change and glowplugs.

thaks for that I will have a look it seems to come on more as the engine gets warmer and the turbo light goes off but i think thats cuz the engine is in limp mode

Share this post


Link to post
Share on other sites

As Andy said, the temp sender above the starter motor, just under the inlet manifold. Could be the sender thats faulty or the wire has broken off (more common). I think it controls the EFI system too.

Pull the ECD relay or disconnect the batteries for 20 mins to re-set the ECU.

Share this post


Link to post
Share on other sites
As Andy said, the temp sender above the starter motor, just under the inlet manifold. Could be the sender thats faulty or the wire has broken off (more common). I think it controls the EFI system too.

Pull the ECD relay or disconnect the batteries for 20 mins to re-set the ECU.

well I will look tomorrow but does the 2.4 definately have one if so any idea where to get replacements

Share this post


Link to post
Share on other sites

Yep, there is a sender unit there. My Surf used to be a 2.4. The sender is a dealer part, about 20 ish quid. Check the wiring first though, as it can get knocked off or get brittle with heat from the engine and break off.

Share this post


Link to post
Share on other sites
Hope this loads ok.
there appears to be two sensors above starter motor which one?

I have three diagrams are they the ones I need to check?

Share this post


Link to post
Share on other sites

hi there, would anyone have engine codes for 1992 hilux surf LN130 series. turbo and engine check light blink alternatively, then i get 11 flashes stop then 2 flashes, car all of a sudden wont start, any help be great as i a newbie and need all the help i can get.  thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this