Jump to content
Do Not Sell My Personal Information


Gen7 Ecu Unit Blown?


J888
 Share

Recommended Posts

Hi evereyone...i need some serious help! :S

I recently got a 2005 gen7 and the ABS light came on causing it to fail MOT.

I took it to the local Toyota dealer who said there is probably a problem with the sensors which will cost around £200 to repair.

Fair enough. I just got a call from them saying that the ECU unit has blown, and its gona cost me more than £1000 to fix!!!!

Can anyone tell me if this is a common problem...or are Toyota trying to get money from me?

And if this is the problem....can it be repaired cheaper elsewhere??

I hope someone can help!

Thanks!

Link to comment
Share on other sites


Hi evereyone...i need some serious help! :S

I recently got a 2005 gen7 and the ABS light came on causing it to fail MOT.

I took it to the local Toyota dealer who said there is probably a problem with the sensors which will cost around £200 to repair.

Fair enough. I just got a call from them saying that the ECU unit has blown, and its gona cost me more than £1000 to fix!!!!

Can anyone tell me if this is a common problem...or are Toyota trying to get money from me?

And if this is the problem....can it be repaired cheaper elsewhere??

I hope someone can help!

Thanks!

ECU's don't just blow. I hope the garage didn't damage it. search bba reman on the web, they can probably fix the ecu for less than a new one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership