jd gul

Registered Member
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jd gul

  • Rank
    New Member

Profile Information

  • First Name
    Junaid
  • Gender*
    Male
  • Toyota Model
    rav4 d4d xt4
  • Toyota Year
    2004
  • Location
    Derbyshire

Recent Profile Visitors

988 profile views
  1. Hi all, I have a Toyota mr2 facelift 55 reg 2005, I am looking to change the gearbox oil Mt90 redline what quantity do I need for my car?, moreover I am struggling to get hold of some driveshaft oil seals for my car anyone know somewhere in Derbyshire that does them?, thank you.
  2. Yh mine performs spot on mechanically too but as u can see my noise is terrible you can hear it from quiet a distance, I want to remedy it at all cost!
  3. did yours happen after a service too?.
  4. I put everything genuine in the car, so I guess I'll try a cheap aftermarket one?, we are told genuine are the best but not in this case I guess.
  5. Hi, I think there must be a connection between the two then graunch. And hi there, it's just that before I had my rav4 serviced it was absolutely perfect no noise nothing and straight after it developed it, I had the service done quiet some miles away so didn't really go back as you said it doesn't affect t the running of the vehicle itself as it doesn't miss a beat, but it's just embarrassing If you like and it's taking a bit of a toll on me at work everyday putting up with it.
  6. I think that's probably the most informative answer I have received!, it's been playing with my head all year happened straight after a service, the mechanicmay have damaged my housing, it's just no one has got it solved but u heard they have improved the part a few times so I'm wondering will it cure it now.
  7. Hi thanks for the reply, but my noise is not from the fuel filte4 area it's from the left. I have now also changed the alternator belt and fitted new alternator still no difference noise still there, do you think it can be the hydraulic lifters?.
  8. My car (Toyota rav4 d4d 2.0 xt4 (2004) manual, developed this noise straight after a service from a mechanic it was perfect before never made a noise. I have tried numerous things in attempt to resolve the issue such as, replacing the alternator and belt, and the power steering belt, none of which have worked, I also recently purchased a used fuel filter housing as I did hear that it's due to the housing (fuel filter cap) by a great man goes by the name of anchorman (don), he kindly installed both filter and housing totally free of charge , I decided to change the fuel filter along with the housing it had a genuine Toyota one last year and that's when the noise started!, when installing the replacement housing I was advised to change the fuel filter (Mann filter), the noise started when genuine filter was installed, soon after the housing was installed it made a small noise and the next day after I pumped the fuel filter housing plunger little black button on top it was okay for a day no noise at all, the noise reappeared after a day and half, the noise has totally disappeared on start up now it was far worse before as you can see in the video, it only makes the sound 10-20 seconds after setting off on cold start. It also occurs when warmed up small little howls, my question is now that it's obviously related to fuel flow etc and noise went away for a while when pumped the fuel filter housing plunger, but I must say 80 % of the noise has gone away, its doesn't occur on start-ups no more, just when the car starts moving (intermittently) what can be still triggering it, can it be that the fuel system is dirty etc, ???!!!, all input will be highly appreciated, especially respected mechanics!!!, car mileage currently (126950) thank you very much!. (Youtube video link for my noise)
  9. Hi, did you manage to get the noise sorted?, i have a Toyota rav4 d4d 2.0 2004 xt4 , there seems to be an odd whining noise coming from alternator area maybe?, it soon started after i got it fully serviced, this included fully synthetic castrol edge oil, oil filter, fuel filter, air filter, pollen filter, sump plug, after it developed the sounds i decided to change the power steering belt but did not change the alternator belt as it seemed to be in good shape, this sound is driving me crazy!!! lol, everytime i cold start the car the sound is there,sometimes it appears when the car is moving , any input would be highly appreciated , and consequently shine some light on this, because its very annoying!!, thanks, this is the link to the sound http://youtu.be/2ChNMS9Ki4c, cheers.