j4nwa

Registered Member
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

1 Neutral

About j4nwa

  • Rank
    New Member

Profile Information

  • First Name
    jan
  • Toyota Model
    avensis
  • Toyota Year
    2008
  • Location
    Lancashire

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. A lot of the time the screws heads are damaged or rusted away or just siezed solid so the easiest way to get them off is hammer the old discs off which would leave the snapped screw threads stopping new screws to be fitted, theres no reason anyone wouldnt fit the old screws back in or fit new ones if they came with the discs, so i think you might find the old ones snapped in the holes, but shouldnt do any harm as the wheel studs through the wheels hold the discs in place anyway:-)
  2. Just incase anyones interested, everyone including toyota main dealers gave up on my car so as i only get thursdays off work its took me a while to get round to it, anyway i decided last week to take top cover off my engine to get to my timing chain when i did it seemed to have excess play in it, so then decided to strip the side cover off & looked like the tentioner had sumhow gone back in & had stuck in due to the ratchet mechanism, i pulled the guide back, twisted the piston on the tentioner & its popped back out taking the slack out of the chain, ordered a new chain kit & set about it today, got it all built back up (not the easiest job ive ever done) turned the key & it started & revd sweet as a nut, happy days Why toyota cudnt take an hour of there time to remove the top of my engine to check the chain is beyond me, rather than fitting umpteen differant parts then expect me to pay for there incompetance which didnt happen, suppose morrel of the story is, just because a computer says that a sensor is at fault doernt neccesarily mean its faulty, could be something else wrong that causing that fault to show up:-/
  3. Just spoke to mechanic & he said after visual inspection looks like the timing marks are correct, not sure if cranks free rolling or keyed, but is it possible to spin slightly enough to still run but be out enough to bring up the cam sensor fault?????
  4. Yeh its been picked up today & gone to the garage, gonna try that but the garage seem to think the timing could be out hence giving the cam sensor fault code so gonna check the chain, if thats feasable
  5. When you clear the fault code then start it up, it starts & revs freely then eng man light comes on & back to not revving again, sometimes it wont start at all as tho it does have a faulty crank or cam sensor but both have been changed, crank it again & starts strait away just wont rev
  6. Ive got a problem with my 2008 2.2d avensis, it just wont rev or does ever so slightly, fault code says camshaft sensor circuit fault, i replaced the sensor with one from a friends identical car & made no differance, fit a new one anyway & still the same, checked pulse in wiring to ecu & alls fine, sent ecu away to be tested & thats fine, gave up & sent to toyota dealers who basically tried allsorts themselves then suggested "an engine strip down to see if they could find anything wrong" but couldnt explain what they were hoping to find, so i had the car picked up & brought back to my house, the car is mint done 100k just banging my head against the wall with it now, so would be grateful of any ideas, thanks all
  7. Just bought my first avensis so thought i'd join the forum & say hi