hambleton1

Registered Member
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

1 Neutral

About hambleton1

  • Rank
    New Member

Profile Information

  • First Name
    Ross
  • Toyota Model
    Yaris
  • Toyota Year
    2009
  • Location
    BlaenauGwent

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. hambleton1

    Buying a Yaris with 'High' Mileage

    Good to hear, thank you.
  2. hambleton1

    Buying a Yaris with 'High' Mileage

    Thanks! Just bought one on Toyota's eBay shop.
  3. hambleton1

    Buying a Yaris with 'High' Mileage

    Just an update to say i've bought the car I mentioned for £2500. It's in very nice condition, I hope it will be as reliable as my old Yaris.
  4. hambleton1

    Buying a Yaris with 'High' Mileage

    Thank you for the replies. Out of interest, what would you expect to pay for a car of this description?
  5. hambleton1

    Buying a Yaris with 'High' Mileage

    Hi All, I'm looking for a new Yaris to replace my current 1999 model. I've found a 2009 one with a 1.33 litre engine and start/stop etc. It also has a full service history, drives nicely, engine runs quietly, bodywork and interior in good condition. However, it has 94,000 miles which I know for it's age is average, but do you think it will last me for the next 5 or 6 years with regular servicing etc.? I average about 8,000 miles per year. Thank you 🙂
  6. Hi All, I have a 1999 Yaris 1.0L. When the engine is fully warmed up the idle drops to around 500-600 RPM, which is supposed to be normal for the Yaris. However, when pressing the accelerator to pull away the engine will almost stall before the revs come up to where they should be. This is particularly bad when needing to pull away quickly because the car won't go for a second or two because the idle drops before rising back again. This doesn't happen when the engine is cold because the idle speed is higher. I hope this makes sense. I've also tried blipping the accelerator in neutral, and it does exactly the same thing. Can anyone help as to what this may be?
  7. hambleton1

    High CO Emissions

    But if the cat isn't working properly and doesn't convert the CO emissions, wouldn't the post-cat oxygen sensor detect this and throw the error code.
  8. hambleton1

    High CO Emissions

    Hi All, My Yaris has just gone over the CO limit on the MOT emissions test. Everything else is normal HC, Lambda etc. The code P0172 is also showing which is "System Too Rich". The car is 19 years old and when it's first started I can smell petrol outside and sometimes when I get out after driving it I can smell it too. I've tried Cataclean and i've also cleaned the MAF. I'm thinking it's the CAT? Any thoughts? Ross.
  9. Hi All, My 1.0L 1999 Yaris had high CO emissions on the MOT report, it passed but was right on the limit. I also used Cataclean before that but obviously it didn't help very much. That was in March, and now a fault code has come up: P0172 System Too Rich. I tried using premium unleaded fuel for a few weeks but the code keeps coming back after I reset it. Does anyone have any ideas as to what is causing these issues? I have attached the emissions report for more detail. Thank You :)
  10. hambleton1

    New Battery Specification

    My existing battery is 45Ah and 300CCA. I've bought the 40Ah now, I was told it should be fine. Thanks for your help
  11. hambleton1

    New Battery Specification

    Thanks, i've looked on Euro Car Parts already and lots of different types come up. I'm hoping 40Ah is enough.
  12. hambleton1

    New Battery Specification

    Hi All, I need a new battery for my 1L 1999 Yaris. I'm looking at a type 063 battery with 340CCA and 40Ah, would this be any good? Thanks :)
  13. Hi All, My 2010 Avensis TR won't start the first time. The engine will crank slowly but it takes a few tries to get it started, the battery has been checked and is fine. Any ideas? Thanks.