Nick7

Registered Member
  • Content Count

    54
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Nick7

  • Rank
    Club Member

Profile Information

  • First Name
    Nick
  • Toyota Model
    Yaris 1.4 D4D Mk 1
  • Toyota Year
    2005
  • Location
    West Midlands

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Did you manage to get this sorted mate? My issue is still ongoing
  2. Hello mate did you manage to get this sorted? I also have a mk1 55 plate Japanese built Yaris d4d and had this issue since purchase. ive been baffled by this issue and the p0380 code for nearly two years now? 2 of my 4 plugs were replaced the other 2 I was told were tight and Could snap so we’re not replaced. Since then I’ve just had to keep clearing the light when it randomly pops up. Never had an issue starting the car first time even in snow. Usually the engine management light comes on after around a minute or so after the car starts up. Not instantly. Would be interested to know if you found a fix. ?
  3. may i direct you to this post which has lead me to believe it may be the injectors:- what do you think? 1 or more injectors pushing out oil to quickly may be the issue???????
  4. Actually thanks for the link to the thread. If not the injectors then may be :- the MAF sensor needs cleaning which hasn’t been done. (Although mine is cutting out at low speeds - under 40mph?) also even after I replaced fuel filter it threw up the drain fuel filter light for a second along with engine management light when it cut out. Or could be maybe egr delete will solve it? Again if it’s these things why is it throwing up fault code p1229???????
  5. Hi madfish. I doubt it’s fuel pump but will have to get a mechanic to check pressure to be sure. Not fuel filler replaced as a matter of course today. Definitely not egr valve was cleaned manually along with throttle body 2k miles ago. Could be accelerator switch. However when it cuts out engine light keeps throwing up error p1229 which is showing as problem with fuel pump/fuel system. Why would it throw up this code over and over even after I try and clear it each time it cuts out if it was the accelerator switch ? Ive been researching various sources all afternoon and the only solution which keeps cropping up where people have solved this intermittent fault is by replacing one or more of the 4 diesel injectors. It seems that it may be that one or more of the injectors may be delivering too much fuel compared to the others causing this issue? Im not sure but obviously if it is the injectors causing it then as you previously suggest it is a job only for a highly qualified diesel mechanic / injector specialist company. I will Remove and clean the sender unit in the fuel tank and clean the fuel heater unit at the top of the filter housing tomorrow also of any gunk but I highly doubt either of these things will resolve this issue. Pretty sure it’s one or more faulty injectors causing this problem which will need to them be replaced. Your thoughts would be appreciated.
  6. Hello caroline did you manage to sort this? I have the same issue. changed the fuel filter but no good. keeps cutting out at low speeds with fault code p1229? could it be the fuel pump or fuel pressure regulator or something else?
  7. Nick7

    D4D Cutting Out

    Hi Will. Did you manage to sort this issue eventually? changed the fuel filter but no good. keeps cutting out at low speeds with fault code p1229? could it be the fuel pump or fuel pressure regulator or something else?
  8. changed the fuel filter but no good. keeps cutting out at low speeds with fault code p1229? could it be the fuel pump or fuel pressure regulator or something else?
  9. changed the fuel filter but no good. keeps cutting out at low speeds with fault code p1229? could it be the fuel pump or fuel pressure regulator or something else?
  10. Hello mate did you managed to find out what was the issue. Im having exactly the same issue and also changed the fuel filter but not good. keeps cutting out at low speeds with fault code p1229? was it the fuel pump or fuel pressure regulator or something else?
  11. Hello cyker & madasafish. I’m having this same issue now with my 1.4 mk1 d4d. Would you please provide me with some more detailed instructions on how exactly to replace my fuel filter? There is nothing in the manual or the Haynes guide about how to do this. My car cut out twice yesterday after nearly 10k miles absolutely issue free since I bought it. It threw up and eml fault code 1229 and also the drain water light came on. So I’m guessing my first port of call would be to replace fuel filter In that time I’ve serviced it twice myself using a method which I read on this very forum. Your swift response would be appreciated. o using biodiesel )
  12. Hello madasafish. I’m having this same issue now with my mk1 d4d (55 plate phase 2 facelift). Would you please provide me with some more detailed instructions on how exactly to replace my fuel filter? There is nothing in the manual or the Haynes guide about how to do this. My car cut out twice yesterday after nearly 10k miles absolutely issue free since I bought it. It threw up and eml fault code 1229 and also the drain water light came on. So I’m guessing my first port of call would be to replace fuel filter In that time I’ve serviced it twice myself using your method which I read on this very forum. Your swift response would be appreciated.
  13. Hey cyber my mk1 d4d has just had this light and the engine management light come on after it cut out on me twice today within 5 minutes. Luckily i managed to pull over safety twice and the 3rd time managed to drive it home and get it parked up safely on my drive. Would you please give me instructions on how you replaced the fuel filter on your mk1 d4d as I cannot find anything in the car manual or in the haynes manual and anything I've read so far is extremely vague for an amateur like myself? also did you replace with an original toyota filter or aftermarket one?
  14. I think you may be right but with my limited knowledge and experience i would not want to risk it. The light has stayed off since so hopefully that remains the case. Regards.
  15. Ok mate nice one. Is this the oil you use :- https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.co.uk%2Fulk%2Fitm%2F361430280535