jimsupersix

Registered Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jimsupersix

  • Rank
    New Member

Profile Information

  • First Name
    James
  • Toyota Model
    Avensis
  • Toyota Year
    2007
  • Location
    Fife
  1. I used to have a gen2 2.4, and I've got the bug again and I want another Surf, this time a 3L to avoid the cylinder head issues of the 2.4 (ended up buying and fitting a new head to my 2.4). Today I've looked at a P-reg Gen3 3L SSR-G, overall in really nice condition, rust on the rear bumper but nothing obvious on the chassis or bodyshell anywhere, all the body seams underneath look nice and tidy. Surface rust on the all suspension but I didn't spot anything too bad. One question I hope someone can answer - I tested the various 4WD and low-range functions, they all seemed to work fine inc. low range, but I found an oddity when changing back into 2H/4H - if I moved the lever back into 2H/4H from 2L/4L the dash indicator light would start to flash all 4 wheels green and the centre diff orange. Only once I started to move the vehicle forwards did it stop flashing and was seemingly back in 2wd. Using just the 4wd button when in either H/L position turned all 4 wheel indicators green both on and off with no problems. Is that normal behavior? It makes me think it needs a bit of forward motion to disengage back into 2wd, but I am not sure - I don't recall my gen2 having this indicator light, just the lever, and being honest I only used 4wd once anyway, and never used low-range, but I don't want to buy a vehicle with a diff or gearbox issue that could develop and affect even 2wd.