Jump to content
Do Not Sell My Personal Information


Iitommoii

Registered Member
  • Posts

    2
  • Joined

  • Last visited

Profile Information

  • First Name
    Bob
  • Toyota Model
    Rav4 t180
  • Toyota Year
    2006
  • Location
    Other/NonUK

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Iitommoii's Achievements

Rookie

Rookie (2/14)

  • One Month Later
  • Dedicated Rare
  • First Post
  • Week One Done
  • Conversation Starter

Recent Badges

0

Reputation

  1. I also have the same problem running a tin of bg244 through it to see if it helps? Car runs fine no loss of oil or water just the red arrow display behind me.
  2. 2007 rav4 t180 110k miles. I get alot I mean alot of white/blue smoke after being stuck in traffic. I have been out on 200+ mile run and nothing at all. But as soon as I hit traffic the smoke starts for about a minute or 2 then clears. It runs perfect no oil or water lose and seems very random about how many times it happens. Some weeks I can happen every day on my 20mile trip to and from work. Other times it can go for weeks without a puff. I have started using some fuel additive and it seams a bit better but as soon as I fill up on cheep fuel the smoke starts again at random. Any ideas or common faults/fixes for this? Thanks
  3. Welcome to Toyota Owners Club - Toyota Forum. Please feel free to browse around and get to know the others. Why not introduce yourself in the New Members section.

×
×
  • Create New...




Forums


News


Membership