Jump to content
Do Not Sell My Personal Information


TJF

Registered Member
  • Posts

    24
  • Joined

  • Last visited

Everything posted by TJF

  1. Hi can anyone help with a little problem I hv with my rear brakes IV renewed everything on the back hub bearing s sensors backing plates disc's pads calliper s drum shoes and the shoes are rubbing even though i hv no hand brake are there different sizes of disc for the back ?
  2. TJF

    Pride And Joy

    Here's my beloved buttercup
  3. TJF

    Oil pump

    Hi have anyone got any input on my oil light is on oil is at correct level engine sounds like a bag of nails probably oil pump is it a big job to replace hv anyone out there had it dun and how much . Kind regards T Francis
  4. TJF

    Tow hook

    Thanks for heads up I got some from Toyota all gud .👍
  5. TJF

    Tow hook

    Hi can anyone tell me wot bolts are used in the bracket for the rear tow hook because believe me iv tried loads your help on this matter is very much appreciated. Ter
  6. Hi ,I'm new to the Toyota owner's club do anyone know y my Yaris started cutting out going along sometimes took ages to start and now turns over but won't start well it fire's in for a second and that's it like it's getting no fuel ? Any suggestions much appreciated
  7. Hi thanks for the insight I'm starting to think u maybe right the wiring to the pump when changed the pump I'm pretty sure the wiring was blue well it looked crap and I can't hear the pump going ?
  8. Hi guys Thanks for your suggestions I got another petrol pump for it and thinking about it when I turn the key I can't hear the pump IV also changed all the relays and the MAF sensor and the crankshaft sensor it fire's but that's it it's like there's no fuel getting thought I'm at a loss ? HELP
  9. Hi I joined, because I'm a massive Toyota Celica fan and yes I have one of which I absolutely adore anyway hi to all you budding Toyota fans . Ter
  10. Hi ,I'm new to the Toyota owner's club do anyone know y my Yaris started cutting out going along sometimes took ages to start and now turns over but won't start well it fire's in for a second and that's it like it's getting no fuel ? Any suggestions much appreciated.
×
×
  • Create New...




Forums


News


Membership