Jump to content
Do Not Sell My Personal Information


Soroco

Registered Member
  • Posts

    7
  • Joined

  • Last visited

Profile Information

  • First Name
    Mick
  • Toyota Model
    Alphard
  • Toyota Year
    2007
  • Location
    Hertfordshire

Soroco's Achievements

Rookie

Rookie (2/14)

  • Week One Done
  • First Post
  • Conversation Starter

Recent Badges

0

Reputation

  1. New alternator fitted stil no joy need to find the fuses that controls the charge from alternator to battery( ecu acc Met ign I think )
  2. I left it disconnected overnight but no joy had a brand new battery fited today still no better . I looked on youtube and I saw something about a relay for the flashers In drivers footwell that controls charging ?
  3. Don't know had lights ,radio heater on. As I was stopping to pick-up a friend it started to loose power and the dash was flashing all the symbols, abs, engine was like a xmas tree . I used a power pack a couple of times to start it but it just dying. Recovery said alternator so I've got one on order. Still have hazards but no indicators or gear position lights on dash.
  4. Hi my indicators stopped working with the gear position lights on dash. Car eventually stopped and battery went flat. I got recovered to home put on a brand new battery now it starts but still have the same 2 faults. Checked alternator charge 11.8 v. Would this have caused the failures above . Any help appreciated
  5. Welcome to Toyota Owners Club - Toyota Forum. Please feel free to browse around and get to know the others. Why not introduce yourself in the New Members section.

×
×
  • Create New...




Forums


News


Membership