BlackRs

Registered Member
  • Content Count

    54
  • Joined

  • Last visited

Community Reputation

0 Neutral

About BlackRs

  • Rank
    Club Member

Profile Information

  • Gender*
    Male
  • Toyota Model
    Corolla 1.4 D4D T3 05
  1. More than 2 yrs ago for sure since I've never changed it and I think it was replaced by the previous owner.. however I would like to change that..any how tos? Ok, so yesterday I just replaced the Diesel Filter ( it was quite intuitive) and this time I cleaned the EGR once again and went a little bit far ie cleaned the throttle body and all the passageways into to block. It already started feeling more responsive and mpg started climbing again.. Hey this EGR is getting more demanding by the day. Even though I could feel a huge difference in the performance, I also felt the engine would leave me when flooring when cold which I might put it down to ecu mapping as a safe mechanism.. good to see you got sorted, well as said above never drive above 2k rpm on a cold engine but to try and keep the egr from blocking try and give it a blow out every few weeks......on a quiet motorway....if you know what i mean, When flooring, I never really meant to hammer it but just push it a bit after heating up the engine... one can't imagine the difference it makes by scooping out all that sooth of her nostrils..
  2. More than 2 yrs ago for sure since I've never changed it and I think it was replaced by the previous owner.. however I would like to change that..any how tos? Ok, so yesterday I just replaced the Diesel Filter ( it was quite intuitive) and this time I cleaned the EGR once again and went a little bit far ie cleaned the throttle body and all the passageways into to block. It already started feeling more responsive and mpg started climbing again.. Hey this EGR is getting more demanding by the day. Even though I could feel a huge difference in the performance, I also felt the engine would leave me when flooring when cold which I might put it down to ecu mapping as a safe mechanism..
  3. More than 2 yrs ago for sure since I've never changed it and I think it was replaced by the previous owner.. however I would like to change that..any how tos?
  4. its mostly town driving since we've got no motorways here..I've cleaned the egr twice in the last year, infact I had posted my first try with pics to serve as a how to for others..anyway it did resolve the 2800 slug moment but after 6 months it comes back...this time i don't know whether its the egr again or the fuel filter..which I didn't replace for the last 2yrs..Anyways how shall I do taht?
  5. Here in Malta we have no option mate..it's the low sulphur 15ppm, so much for customer's ample choice! Anyways I've put a Slick 50 Injector Cleaner a couple of months ago ..but now it's getting more irritating as the weather;s getting colder...
  6. hello BLACKRS you'd think in complex (EGR; fuel fillter; injectors; air filter; air in the fuel injection system)--the problem must be there. cheers/Igor But why does it happen when cold?
  7. Guyz, I would appreciate some help since I received no feedback in my last plea for help... Practically the situation is happening whenever the engine is cold and occasionally happens even when the engine is warmed up... EGR? nope I've cleaned it...could it be the diesel filter ? (even though no check light is on)?
  8. Ok, first of all thanks for your feedback guys.. secondly I really don't know from where to start..maybe I can try the cheapest solutions.. Here in Malta we don't have any choice..it's just plain Low-Sulphur Diesel and that's what you'll get but I highly suspect that that's the culprit.. So just to give you an overview mine has clocked 74kmiles and have had all scheduled services done in UK every 10kmiles and if all done well (namely U-Drive, Inchcape, KPR and Octagon at Berkshire) am pretty sure they're serious and followed the service replacement guidelines to the book. If that's the case the fuel filter must have been changed as indicated every 6 yrs or 40miles whichever comes first which surely my car have done at octagon.. Albeit this when I imported the car I noticed the fuel filter harness was unplugged and when I connected it the warning light stayed off which meant it either loosen during the long trip or else they simply forgot to plug it in. And that's giving me another indication the fuel filter might have been changed.. As for the past 2yrs I drove in Malta my regular 6month services included changing twice the engine oil + filter, Air filter, Cleaned EGR Twice, Gear Oil Changed, Pads all round, which shows the pampering I'm giving her to keep her in good nick.. So the question stands.. How can I know the fuel filter is to replace if the lamp's still off? From where can I start to identify the problem..cheap fixes being first :P
  9. I already had my EGR valve cleaned (as shown in my previous threads) last one only goes back to a couple of months ago. Now, i've got a different problem, while accelerating hard 2nd or 3rd I notice a non-constant pull every 500rpm or so near the 2500rpm mark..Got any ideas?
  10. Till now I saw a 15% increase in mileage. Are you sure you plugged back all the connections back to their place? yea i put everything back ok, car is driving perfect and mpg is way up, did yous disconnect the battery to reset the ecu or anything ? nope, I didn't disconnect the battery.. was in with Mr.T yesterday, egr valve coming up on the computer now when i put it back on there was a slight bit of bubbling coming from it, this stopped after a minute or two, iam wondering if maybe she needs to be tightened a bit more or if i need a new gasket ? also instead of using carb-cleaner (i hope iam not going to be laughed at for this) i used white sprits ???? does this matter ??? the car is running perfect.......... Guys I maybe just being paranoid but lately I'm noticing that whenever the car is not warmed up (ie gauge is not indicating half the cold/hot reading) and I would floor it (yes I know I shouldn't do it) the acceleration hangs out abit every 1000 revs or so, but this is doesnt happen when it's warmed up.. Question being..is there something from the ecu restricting the acceleration or the EGR is at it again? I've just cleaned it again after 3 months since it was manifesting the same 3k rpm hangabout and got it fixed with the cleanup. Another one.. is it only the EGR which fouls up since I couldn't not notice that the culprit might not be the EGR but any other passage from/to it ..anyone can shed some light on some exploded views of the 1.4 D4D?
  11. Can anyone owning a 1.4D4D Corolla tell me whether he ever felt his clutch pedal much harder to press unlike other petrol engine driven cars? If no, can you tell me how to solve this, (without changing the clutch slave cylinder)?
  12. Pals, I've got a couple of issues with my corolla 1.4 D4d 72kmiles which I would like to fix myself if possible, here they are.. a ) Humming sound mostly audible when keeping engine revved to 2krpm and with windows closed. b ) Creaky sounds from front brake calipers (I already tried greasing all these bits including spraying some lube inside the piston lining aswell but this only silenced the noise for a week). c ) Creaky sounds from clutch slave cylinder from inside footwell. (Sound is temporarily eliminated by pressing the clutch pedal and spraying some lube inside the slave cylinder...this solution only lasts a week aswell) This is my final shot before turning my corolla to a Toyota Repair Centre and wait for a hefty bill. All help is greatly appreciated
  13. Till now I saw a 15% increase in mileage. Are you sure you plugged back all the connections back to their place? yea i put everything back ok, car is driving perfect and mpg is way up, did yous disconnect the battery to reset the ecu or anything ? nope, I didn't disconnect the battery..
  14. Till now I saw a 15% increase in mileage. Are you sure you plugged back all the connections back to their place?