Jump to content
Do Not Sell My Personal Information


FROSTYBALLS

Management
  • Content Count

    26,770
  • Joined

  • Last visited

  • Days Won

    517

FROSTYBALLS last won the day on June 18

FROSTYBALLS had the most liked content!

Community Reputation

3,660 Excellent

About FROSTYBALLS

Profile Information

  • First Name
    Mike
  • Contributor
    5
  • Gender*
    Male
  • Toyota Model
    2020 Hyundai i20 Play & 2016 Toyota Aygo X-Play with X-Touch
  • Toyota Year
    2016
  • Location
    West Midlands

Recent Profile Visitors

114,719 profile views

Single Status Update

See all updates by FROSTYBALLS

  1. Hi looking for some help and advise please. We have a 2004 Toyota Corolla 2.0 d4d vacuum pump for servo failing after 10 minutes driving causing stiff brake pedal and power loss. After replacing with a donor pump. fault returned on startup mitivac reads around 22mg of vacuum this eventually drops to around 8mg after warmup. Question I need answered is how much oil pressure needs to be sent to vacuum pump as when pump removed and running, a snail trail of oil appears from feed hole. Not sure if this is acceptable or if donor pump is faulty. Any help or input would be appreciated 

     

    Thank you 

    1. gmsjack

      gmsjack

      I have just joined this forum today and looking for some help and advise please, can anyone help out???

    2. FROSTYBALLS

      FROSTYBALLS

      Posting on my status means that only I will see your query.

      You need to post your query as a new topic in the Corolla club section - see https://www.toyotaownersclub.com/forums/forum/50-corolla-club/

×
×
  • Create New...




Forums


News


Membership