Jump to content
Do Not Sell My Personal Information


sconnochie

Registered Member
  • Posts

    4
  • Joined

  • Last visited

Everything posted by sconnochie

  1. since my last post regarding foaming coolant I have replace the thermostat and tried to purge the system of any air locks.No change, however I have just noticed water seeping from the front pully area, cant investigate further as I am at work. Still geting streams of small bubbles through the coolant while the engine idles(all temperatures). Could I be drawing air at the water pump and dropping coolant? Or is looking more likely that the coolant system is getting pressurised from the cylinder head and has blown the pump seal?
  2. Replaced the thermostat yesterday and ran the engine for about 30 min with a header tank on the radiator, a fair quantity of bubbles were displaced once the thermostat opened before eventually settling down. I am hoping this has resolved my problem but may look for some more help if I drop any coolant over the next few days. regards Steve Connochie
  3. Yes indeed I have just changed the oxygen sensor in my 1997 carina and if you are anything like me you will have been gobsmacked at the £300+ tag on a piddly sensor. I had problems tracking down a universal replacement as finding out what engine type I had was a real pain. Eventually got the info from toyota tech team. If the sensor is on the front of the engine on the manifold its a lean burn and thats the expensive one. If its on the down pipe it could still be one of two others. I got a lot of help from a guy at lgpkits.com who advised and got me a replacement for £225 as a favour. If you engine is not lean burn you can get a replacement for about £65 from these guys. Dont buy second hand ones and finally did you reset the ecm by pulling the fuse for 30 seconds?
  4. Hi I need some help form anyone who has had a similar problem. I recently had to replace the radiator in my carina(1997) although it had been leaking the temp sensor showed normal. After this I was still losing coolant and noticed that the coolant was like foam. The radiator shop suggested a bust head gasket so I have just replaced that. the head was checked for warping by a specialist and was ok. Engine reassembled I still have the same problem. Someone has suggested I may have an air lock is this likely or am I looking at a new cylinder head? Regards S Connochie
×
×
  • Create New...




Forums


News


Membership