• Join Premium & Save
      Join Premium & Save
    • 1000's Of Toyota Cars For Sale
      1000's Of Toyota Cars For Sale
    • Get Your Club Gear!
      Get Your Club Gear!
    • Huge Range of Toyota Parts
      Huge Range of Toyota Parts
    • Save Up To 15% Off For Members
      Save Up To 15% Off For Members
    • Review Your Toyota
      Review Your Toyota


AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Boco77

Can't Change Front Wiper Blade

12 posts in this topic

I'm having a problem with a new wiper blade I got for my aygo. Its a Bosch no.26 from halfords and i just cannot get it on. One of the reasons being because Of the wiper arm that is attached to the aygo only lifts up a little bit and not fully upwards like other wiper parts on cars do. It will only lift up a little bit and i can't get the blade through it because the arm is too low and won't lift enough. Any advice?

Share this post


Link to post
Share on other sites
 

I'm having a problem with a new wiper blade I got for my aygo. Its a Bosch no.26 from halfords and i just cannot get it on. One of the reasons being because Of the wiper arm that is attached to the aygo only lifts up a little bit and not fully upwards like other wiper parts on cars do. It will only lift up a little bit and i can't get the blade through it because the arm is too low and won't lift enough. Any advice?

If you do a search on this site, there are some instructions.

I'll have a look and try to post links......

Found it......

http://www.toyotaownersclub.com/forums/index.php?showtopic=94014&st=0&p=857933&hl=wiper%20&fromsearch=1entry857933

Ian.

Share this post


Link to post
Share on other sites

I'm having a problem with a new wiper blade I got for my aygo. Its a Bosch no.26 from halfords and i just cannot get it on. One of the reasons being because Of the wiper arm that is attached to the aygo only lifts up a little bit and not fully upwards like other wiper parts on cars do. It will only lift up a little bit and i can't get the blade through it because the arm is too low and won't lift enough. Any advice?

If you do a search on this site, there are some instructions.

I'll have a look and try to post links......

Found it......

http://www.toyotaownersclub.com/forums/index.php?showtopic=94014&st=0&p=857933&hl=wiper%20&fromsearch=1entry857933

Ian.

It's putting the new one that i have a problem with not taking the old one off which I did already. I can't get the new one on as the arm wont lift high enough for that

Share this post


Link to post
Share on other sites

Fitting You New Wiper Blade

An adapter connects the blade assembly to the windscreen wiper arm. To remove the old blade assembly:

1. Pull the end of windscreen wiper arm outward to move the arm away from the windscreen.

Take care not to let it spring back against the windscreen.

2. Press the tab on the adapter to release the adaptor mechanism.

3. On all standard windscreen wiper arms: Maintain pressure on the tab while pulling the blade assembly downward to slide it out of the recess, or hook on the wiper arm.

Share this post


Link to post
Share on other sites

I'm having a problem with a new wiper blade I got for my aygo. Its a Bosch no.26 from halfords and i just cannot get it on. One of the reasons being because Of the wiper arm that is attached to the aygo only lifts up a little bit and not fully upwards like other wiper parts on cars do. It will only lift up a little bit and i can't get the blade through it because the arm is too low and won't lift enough. Any advice?

If you do a search on this site, there are some instructions.

I'll have a look and try to post links......

Found it......

http://www.toyotaownersclub.com/forums/index.php?showtopic=94014&st=0&p=857933&hl=wiper%20&fromsearch=1entry857933

Ian.

It's putting the new one that i have a problem with not taking the old one off which I did already. I can't get the new one on as the arm wont lift high enough for that

CAREFULLY......

See if the little piece that the curved end of the wiper

arm hooks onto is removeable from the rest of the wiper.

I had to do that to one of the flat blade wipers I

fiited to either my or the wife's Aygo.

ie......Remove the little adapter, slide it into the arm hook

then place the wiper onto the screen and push your assembled arm

back into place.

Have a good careful look first as most modern stuff is made

of "snap" or "brittle".

Share this post


Link to post
Share on other sites

I'm having a problem with a new wiper blade I got for my aygo. Its a Bosch no.26 from halfords and i just cannot get it on. One of the reasons being because Of the wiper arm that is attached to the aygo only lifts up a little bit and not fully upwards like other wiper parts on cars do. It will only lift up a little bit and i can't get the blade through it because the arm is too low and won't lift enough. Any advice?

Ive got some advice don't buy anything from halfrauds :P, Aygo wipers are 30 something pounds, and you can get flat blades for less than 10 pounds on e-bay :)

Share this post


Link to post
Share on other sites

Bought a new one from Halfords last friday £14, dead easy to fit no probs.

Share this post


Link to post
Share on other sites

I'm having a problem with a new wiper blade I got for my aygo. Its a Bosch no.26 from halfords and i just cannot get it on. One of the reasons being because Of the wiper arm that is attached to the aygo only lifts up a little bit and not fully upwards like other wiper parts on cars do. It will only lift up a little bit and i can't get the blade through it because the arm is too low and won't lift enough. Any advice?

You could always go back to Halfords and pay them £1.99 to fit it for you.

You don't need to lift the wiper arm more than a few inches to fit a new blade anyway.

Share this post


Link to post
Share on other sites

I just bought a new flatblade wiper from here, It's an Autocar 2009 winner and cheap as chips:

Click here...

Share this post


Link to post
Share on other sites

30 quid for the front blade where do you shop ? got mine from Gordon Lamb chesterfield for 10.74 incl vat

Share this post


Link to post
Share on other sites

I timed myself and I took 52 seconds to take off the old one a fit the new flatblade. biggrin.gif

Excuse the quality but I took it with my mobile.

IMG00018.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0