Jump to content
Do Not Sell My Personal Information


Any advice


Recommended Posts

Hi, I have a 2014 Argo play which is a great little car for me and up until about a month ago had never given me any problems. However , 3 times recently the car has started normally and been fine until I’ve needed to stop for a couple of minutes and switch the engine off , then when I’ve tried to start the engine again it’s as if the Battery is dead! Absolutely nothing! I’ve found if I leave it for 5 minutes or so it will then start as normal. Very odd and baffling me. I will get it booked in to be looked at asap but really want to go with s little knowledge if anyone can help??

Link to post
Share on other sites

I'd bite the bullet and have it looked at...maybe a code read...guessing can be expensive.!

Might be worth checking the Battery connections though..make sure they are clean and tight,

Link to post
Share on other sites

I was going to suggest seeing if the Battery clamps needed nipping up as well. First thing to check.

Is it dead as in no dash lights, headlights won't flash, radio won't work etc or dead as in it just won't turn over but everything else seems OK?

 

 

Link to post
Share on other sites

Hi, it’s as if everything is dead and the ignition just does a couple of clicks. After 5/10 minutes though it starts again and seems fine! Just trying to get hold of my Toyota branch but they’re obviously not answering the phones yet 🤣

Link to post
Share on other sites

2 hours ago, RUToyota said:

I'd bite the bullet and have it looked at...maybe a code read...guessing can be expensive.!

Might be worth checking the battery connections though..make sure they are clean and tight,

Thank you, will do

Link to post
Share on other sites

Hiya............agree with above about getting it checked.......my money would say a loose Battery terminal (earth side) or loose other end of earth cable where bolted to chassis ....please let us know the outcome 😉

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...