Sign in to follow this  
neilgk

2019 RAV4 SatNav failure

Recommended Posts

Driving Eastbound on the M62 on 27th December, with the SatNav destination set for my home, near Sheffield.  Approaching junction 20, the SatNav wanted me to leave the M62 and apparently follow the M627 towards Oldham. I thought this extremely dubious, so I continued on the M62. At the next 2 junctions the SatNav wanted me to leave the M62, but I declined.

Suddenly the SatNav display had us driving across open country and kept issuing meaningless instructions. My Wife re-entered our destination but this didn't fix it. By the time we actually got home, the Sat Nav had us 35 miles away, somewhere near the M62!!. Oh and only 10 minutes later than our original ETA when we left our start point, the 10 minutes being attributable to a comfort stop!

Switching off the engine and restarting almost immediately didn't fix it; leaving it switched off for about 20 minutes did allow the SatNav to "recover" and show us that we were indeed "home"!!!

Is this something known about? Can I fix it with an update? Should I take it back to the dealership?

I should say I had the SatNav updated in early November, a week after taking delivery of the vehicle, because it couldn't (and still can't!!) recognise my home postcode, which is NOT new.

 

Share this post


Link to post
Share on other sites

Hi

It sounds like it wanted to take you over the A628 to Sheffield due to a build up of traffic at Leeds.

I have had mine glitch like this about 6-8 times over the last 4 years, and my car now has over 11000 miles on it.

I wouldn't bother taking to the dealers unless its starts happening frequently.

Share this post


Link to post
Share on other sites

I've got a 2019 Corolla and on 31st Dec 2019 heading home from Teignmouth, sat nav gave the correct distance & the right time to home. However on leaving a farm & getting onto the highway the sat nav showed us on the wrong road heading in the wrong direction. After about 10 minutes it showed us driving over a cliff & into the English Channel. The land disappeared and we were told to turn right, then silence. I stopped for fuel and when the system rebooted it was fine. 

It was lucky I knew the way or I might have ended up in the sea. It seems strange that when the system is so wrong it doesn't reboot itself. 

I wondered if it was atmospherics stopping the satellite signal. But if so I think it should have connected earlier. 

Very worrying 

Share this post


Link to post
Share on other sites

I’ve also had this happen to me a few times with my satnav. It’s been the worst performing satnav I’ve used. Frequently wants to go cross country and avoid motorways even when using internet for traffic. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this