Jump to content


Photo
- - - - -

Engine Making Bad Rattling Noise


  • Please log in to reply
1 reply to this topic

#1 Huon.cloutier

Huon.cloutier

    New Member

  • Registered Member
  • 17 posts
  • First Name:Huon
  • Gender*:Male
  • Toyota Model: toyota prado
  • Year: 2009
  • Location: Other/NonUK

Posted 14 November 2011 - 12:04 PM

Please help me troubleshoot a problem with my ol 400. Suddenly, it is making extreme rattling noises (is that what pinging sounds like) when under load. It is also idling really rough. It starts right up so obviously it has gas and spark. So is it the timing? Could it be the electronic ignition module. Could it be the vacuum advance on the distributor? Please give me some ideas on how to diagnose it.

Have something to contribute?

Sign in or register to start a topic...


Sign up to TOC Premium Membership To Remove These Ads

#2 dervdave

dervdave

    The biggest Victor Meldrew

  • Registered Member
  • PipPipPipPipPipPipPipPip
  • 1,482 posts
  • First Name:Dave
  • Gender*:Male
  • Toyota Model: Hilux 3.0d Invincible D/Cab
  • Year: 2013
  • Location: Tyne & Wear

Posted 14 November 2011 - 01:42 PM

Please help me troubleshoot a problem with my ol 400. Suddenly, it is making extreme rattling noises (is that what pinging sounds like) when under load. It is also idling really rough. It starts right up so obviously it has gas and spark. So is it the timing? Could it be the electronic ignition module. Could it be the vacuum advance on the distributor? Please give me some ideas on how to diagnose it.


You`ve posted your query in the wrong section my friend :)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users